diff mbox series

[bug#61611,04/10] gnu: Add julia-earthorientation.

Message ID 20230219000453.20559-4-sharlatanus@gmail.com
State New
Headers show
Series : gnu: Add julia-astrotime | expand

Commit Message

Sharlatan Hellseher Feb. 19, 2023, 12:04 a.m. UTC
* gnu/packages/julia-xyz.scm (julia-earthorientation): New variable.
---
 gnu/packages/julia-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index bbc1985a4b..a0a24e05a5 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1829,6 +1829,31 @@  (define-public julia-dualnumbers
 combinations of dual numbers with predefined Julia numeric types.")
     (license license:expat)))
 
+(define-public julia-earthorientation
+  (package
+    (name "julia-earthorientation")
+    (version "0.7.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaAstro/EarthOrientation.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1fschx4qmfd83q0ymgbzqi1dl0drbh45cd7hlcbqnm9lfmw2d847"))))
+    (build-system julia-build-system)
+    (propagated-inputs
+     (list julia-leapseconds
+           julia-optionaldata
+           julia-remotefiles))
+    (home-page "https://github.com/JuliaAstro/EarthOrientation.jl")
+    (synopsis "Calculate Earth orientation parameters from IERS tables in Julia")
+    (description
+     "This package provides a functionality to calculate Earth orientation parameters
+with data retrieved from @acronym{IERS, International Earth Rotation Service}.")
+    (license license:expat)))
+
 (define-public julia-ellipsisnotation
   (package
     (name "julia-ellipsisnotation")