diff mbox series

[bug#61611,01/10] gnu: Add julia-leapseconds.

Message ID 20230219000453.20559-1-sharlatanus@gmail.com
State New
Headers show
Series : gnu: Add julia-astrotime | expand

Commit Message

Sharlatan Hellseher Feb. 19, 2023, 12:04 a.m. UTC
* gnu/packages/julia-xyz.scm (julia-leapseconds): New variable.
---
 gnu/packages/julia-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 82429c957d..b391fadd36 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -3576,6 +3576,31 @@  (define-public julia-lazyarrays
 implementation of matrix-free methods for iterative solvers.")
     (license license:expat)))
 
+(define-public julia-leapseconds
+  (package
+    (name "julia-leapseconds")
+    (version "1.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaTime/LeapSeconds.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "13xa49dx11n7ii77rw6300h1rfl4qlq05ypsprvfmvyww81angkp"))))
+    (build-system julia-build-system)
+    (native-inputs
+     (list julia-erfa))
+    (home-page "https://github.com/JuliaTime/LeapSeconds.jl")
+    (synopsis "Leap seconds in Julia")
+    (description
+     "@code{LeapSeconds} provides a functionality to return the difference
+between @acronym{TAI, International Atomic Time} and @acronym{UTC, Coordinated
+Universal Time} or vice versa for a given date.  For dates after 1972-01-01, this
+is the number of leap seconds.")
+    (license license:expat)))
+
 (define-public julia-linesearches
   (package
     (name "julia-linesearches")