diff mbox series

[bug#61611,02/10] gnu: Add julia-optionaldata.

Message ID 20230219000453.20559-2-sharlatanus@gmail.com
State New
Headers show
Series : gnu: Add julia-astrotime | expand

Commit Message

Sharlatan Hellseher Feb. 19, 2023, 12:04 a.m. UTC
* gnu/packages/julia-xyz.scm (julia-optionaldata): New variable.
---
 gnu/packages/julia-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index b391fadd36..7eb4cb0dae 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -4284,6 +4284,29 @@  (define-public julia-optimtestproblems
 JuliaNLSolvers packages.")
     (license license:expat)))
 
+(define-public julia-optionaldata
+  (package
+    (name "julia-optionaldata")
+    (version "1.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/helgee/OptionalData.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "11js258j7cz6362ijsi24nih3lx90aalf8k1n3fv6v7iqas8bz5s"))))
+    (build-system julia-build-system)
+    (home-page "https://github.com/helgee/OptionalData.jl")
+    (synopsis "Work with global data that might not be available")
+    (description
+     "This package provides the @code{@@OptionalData} macro and the corresponding
+OptData type which is a thin wrapper around a nullable value (of type @code{Union{T,
+Nothing} where T)}.  It allows you to load and access globally available data at
+runtime in a type-stable way.")
+    (license license:expat)))
+
 (define-public julia-orderedcollections
   (package
     (name "julia-orderedcollections")