diff mbox series

[bug#61611,10/10] gnu: Add julia-astrotime.

Message ID 20230219000453.20559-10-sharlatanus@gmail.com
State New
Headers show
Series : gnu: Add julia-astrotime | expand

Commit Message

Sharlatan Hellseher Feb. 19, 2023, 12:04 a.m. UTC
* gnu/packages/julia-xyz.scm (julia-astrotime): New variable.
---
 gnu/packages/julia-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index a07326df6f..a1561f575e 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -262,6 +262,36 @@  (define-public julia-arraylayouts
 much wider class of matrix types than Julia's in-built @code{StridedArray}.")
     (license license:expat)))
 
+(define-public julia-astrotime
+  (package
+    (name "julia-astrotime")
+    (version "0.7.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaAstro/AstroTime.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "032hlanan49ypqh4lwlf91pg7052c8h5sgbxqc1771b8j9srbyd2"))))
+    (build-system julia-build-system)
+    (native-inputs
+     (list julia-measurements))
+    (propagated-inputs
+     (list julia-erfa
+           julia-earthorientation
+           julia-itemgraphs
+           julia-macrotools
+           julia-muladdmacro
+           julia-reexport))
+    (home-page "https://github.com/JuliaAstro/AstroTime.jl")
+    (synopsis "Astronomical time keeping in Julia")
+    (description "@code{AstroTime.jl} provides a high-precision, time-scale
+aware, @code{DateTime}-like data type which supports all commonly used
+astronomical time scales.")
+    (license license:expat)))
+
 (define-public julia-automa
   (package
     (name "julia-automa")