diff mbox series

[bug#61611,03/10] gnu: Add julia-remotefiles.

Message ID 20230219000453.20559-3-sharlatanus@gmail.com
State New
Headers show
Series : gnu: Add julia-astrotime | expand

Commit Message

Sharlatan Hellseher Feb. 19, 2023, 12:04 a.m. UTC
* gnu/packages/julia-xyz.scm (julia-remotefiles): New variable.
---
 gnu/packages/julia-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Simon Tournier March 8, 2023, 5:37 p.m. UTC | #1
Hi,

Sorry for being late.  I have seen that Ludo pushed the series.  Cool!


On Sun, 19 Feb 2023 at 00:04, Sharlatan Hellseher <sharlatanus@gmail.com> wrote:

> +     '(#:tests? #f)) ; Tests try to download from Internet.

Question: Is it possible to disallow the tests that require Internet or
is it the whole test suite?

Cheers,
simon
Sharlatan Hellseher March 8, 2023, 11:26 p.m. UTC | #2
Hi Simon,

I'll check it in the next packaging round, but base on the package name and
description it could be the whole test suit is to download remote data :-)

Regards,
Oleg

On Wed, 8 Mar 2023, 17:51 Simon Tournier, <zimon.toutoune@gmail.com> wrote:

> Hi,
>
> Sorry for being late.  I have seen that Ludo pushed the series.  Cool!
>
>
> On Sun, 19 Feb 2023 at 00:04, Sharlatan Hellseher <sharlatanus@gmail.com>
> wrote:
>
> > +     '(#:tests? #f)) ; Tests try to download from Internet.
>
> Question: Is it possible to disallow the tests that require Internet or
> is it the whole test suite?
>
> Cheers,
> simon
>
diff mbox series

Patch

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 7eb4cb0dae..bbc1985a4b 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -5001,6 +5001,31 @@  (define-public julia-reexport
     (description "This package provides tools to re-export modules and symbols.")
     (license license:expat)))
 
+(define-public julia-remotefiles
+  (package
+    (name "julia-remotefiles")
+    (version "0.5.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/helgee/RemoteFiles.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1zpklzpd4ckp7s4wbf93qmq3dyyrx4pzl41x5i9zbiskadhniqnh"))))
+    (build-system julia-build-system)
+    (arguments
+     '(#:tests? #f)) ; Tests try to download from Internet.
+    (propagated-inputs
+     (list julia-fileio julia-http))
+    (home-page "https://github.com/helgee/RemoteFiles.jl")
+    (synopsis "Download files from the Internet and keep them up-to-date")
+    (description
+     "This package provides a functionality of files download with cURL, wget or
+@code{HTTP.jl} backends.")
+    (license license:expat)))
+
 (define-public julia-referencetests
   (package
     (name "julia-referencetests")