diff mbox series

[bug#61220,07/10] gnu: Add r-snapcgh.

Message ID 20230202022657.67003-7-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#61220,01/10] gnu: Add r-glad. | expand

Commit Message

Mădălin Ionel Patrașcu Feb. 2, 2023, 2:26 a.m. UTC
* gnu/packages/bioconductor.scm (r-snapcgh): New variable.
---
 gnu/packages/bioconductor.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index f692114754..bce8319dcb 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -18185,6 +18185,33 @@  (define-public r-pathview
 large-scale and fully automated analysis.")
     (license license:gpl3+)))
 
+(define-public r-snapcgh
+  (package
+    (name "r-snapcgh")
+    (version "1.68.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "snapCGH" version))
+              (sha256
+               (base32
+                "1zxvl8mkby7yb5kppddag6k9w78d1fm6adx52h4cgrfckn28w64q"))))
+    (properties `((upstream-name . "snapCGH")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-acgh
+           r-cluster
+           r-dnacopy
+           r-glad
+           r-limma
+           r-tilingarray))
+    (home-page "https://bioconductor.org/packages/snapCGH")
+    (synopsis "Segmentation, normalisation and processing of the aCGH data")
+    (description
+     "This package provides methods for segmenting, normalising and processing
+aCGH data.  snapCGH also includes plotting functions for visualising raw and
+segmented data for individual and multiple arrays.")
+    (license (list license:gpl2+ license:gpl3+)))) ;; expanded from GPL
+
 (define-public r-snpstats
   (package
     (name "r-snpstats")