diff mbox series

[bug#61220,01/10] gnu: Add r-glad.

Message ID 20230202022657.67003-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#61220,01/10] gnu: Add r-glad. | expand

Commit Message

Mădălin Ionel Patrașcu Feb. 2, 2023, 2:26 a.m. UTC
* gnu/packages/bioconductor.scm (r-glad): New variable.
---
 gnu/packages/bioconductor.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)


base-commit: 6564a04efaf506a5ef51a7c100144fa31bbe1f31

Comments

Ricardo Wurmus Feb. 7, 2023, 9:31 a.m. UTC | #1
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

> * gnu/packages/bioconductor.scm (r-glad): New variable.
[…]

Thanks for this patch series.

I applied them all after changes to the description of almost all
packages, and changes to the line comments.  I also moved gsl from
propagated-inputs to inputs.
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 711b988e7f..451dcfde86 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6122,6 +6122,31 @@  (define-public r-genomicranges
 manipulating genomic intervals and variables defined along a genome.")
     (license license:artistic2.0)))
 
+(define-public r-glad
+  (package
+    (name "r-glad")
+    (version "2.62.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "GLAD" version))
+              (sha256
+               (base32
+                "0gb52ic5r6nkgm2ynm174vcvbmkbhhjgv71lsmxpxzcsb6rr7qj6"))))
+    (properties `((upstream-name . "GLAD")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list gsl
+           r-aws))
+    (native-inputs (list pkg-config))
+    (home-page "http://bioinfo.curie.fr")
+    (synopsis "Gain and loss analysis of DNA")
+    (description
+     "This package helps with the analysis of array @acronym{CGH, comparative
+genomic hybridization} data by detecting of the breakpoints in the genomic profiles
+and assignment of a status (gain, normal or loss) to each chromosomal regions
+identified.")
+    (license license:gpl2)))
+
 (define-public r-gostats
   (package
     (name "r-gostats")