diff mbox series

[bug#61220,10/10] gnu: Add r-adacgh2.

Message ID 20230202022657.67003-10-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#61220,01/10] gnu: Add r-glad. | expand

Commit Message

Mădălin Ionel Patrașcu Feb. 2, 2023, 2:26 a.m. UTC
* gnu/packages/bioconductor.scm (r-adacgh2): New variable.
---
 gnu/packages/bioconductor.scm | 44 +++++++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)

Comments

Ricardo Wurmus Feb. 7, 2023, 9:30 a.m. UTC | #1
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

> * gnu/packages/bioconductor.scm (r-adacgh2): New variable.
[…]
>  (define-module (gnu packages bioconductor)
>    #:use-module ((guix licenses) #:prefix license:)
> +  #:use-module (guix gexp)
[…]
> +    (arguments
> +     (list
> +      #:phases
> +      #~(modify-phases %standard-phases
> +          (add-before 'configure 'set-PYTHONPATH
> +            (lambda _
> +              (setenv "PYTHONPATH"
> +                      (string-append (getcwd) ":"
> +                                     (getenv "GUIX_PYTHONPATH"))))))))

This phase seems unnecessary.

> +    ;; This is needed by toMap.py script which is not compatible with python3
> +    (inputs (list python2-minimal))

The only reason for Python 2 is the outdated “print”, which is not
called as a function but used as a statement.  I patched it instead.
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c509dffb4c..b351936cd8 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -31,6 +31,7 @@ 
 
 (define-module (gnu packages bioconductor)
   #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix gexp)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
@@ -1800,6 +1801,49 @@  (define-public r-absseq
 ranking by fold-change and visualization.")
     (license license:gpl3+)))
 
+(define-public r-adacgh2
+  (package
+    (name "r-adacgh2")
+    (version "2.38.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "ADaCGH2" version))
+       (sha256
+        (base32 "0g9x3lnr56035wq9ijdcri4sz5pwj8184yxm415gmsxrii9xvpfd"))))
+    (properties `((upstream-name . "ADaCGH2")))
+    (build-system r-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'configure 'set-PYTHONPATH
+            (lambda _
+              (setenv "PYTHONPATH"
+                      (string-append (getcwd) ":"
+                                     (getenv "GUIX_PYTHONPATH"))))))))
+    ;; This is needed by toMap.py script which is not compatible with python3
+    (inputs (list python2-minimal))
+    (propagated-inputs
+     (list r-acgh
+           r-bit
+           r-cluster
+           r-dnacopy
+           r-ff
+           r-glad
+           r-snapcgh
+           r-tilingarray
+           r-waveslim))
+    (home-page "https://github.com/rdiaz02/adacgh2")
+    (synopsis "Big data analysis from aCGH experiments")
+    (description
+     "This package analysis and creates plotts of array @acronym{CGH, comparative
+genomic hybridization} data.  Also, it allows usage of @acronym{CBS, Circular
+Binary Segementation}, wavelet-based smoothing, HMM, BioHMM, GLAD, CGHseg.  Most
+computations are parallelized (either via forking or with clusters, including MPI
+and sockets clusters) and use ff for storing data.")
+    (license license:gpl3+)))
+
 (define-public r-adam
   (package
     (name "r-adam")