diff mbox series

[bug#57737,09/22] gnu: Add emacs-eval-in-repl-python.

Message ID 20220911181611.4171-9-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#57737,01/22] gnu: Add emacs-eval-in-repl. | expand

Commit Message

Nicolas Graves Sept. 11, 2022, 6:15 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-eval-in-repl-python): New variable.
---
 gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0c50cfdcb7..c1c817ab15 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27268,6 +27268,32 @@  (define-public emacs-eval-in-repl-hy
 called @code{ess-eval-region-or-line-and-step}, which is assigned to
 C-RET.  This function sends a line or a selected region to the corresponding
 shell (R, Julia, Stata, etc) visibly.  It also start up a shell if there is
+none.")
+    (license license:expat)))
+
+(define-public emacs-eval-in-repl-python
+  (package
+    (name "emacs-eval-in-repl-python")
+    (version "0.9.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://raw.githubusercontent.com/kaz-yos/eval-in-repl/"
+             version "/eval-in-repl-python.el"))
+       (sha256
+        (base32
+         "06abhykzz41wz8h3gr0x0ljiva9rfgpagija24afpdg8l2w0b3jn"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-eval-in-repl))
+    (home-page "https://github.com/kaz-yos/eval-in-repl")
+    (synopsis "Consistent evaluation interface for Python REPLs for emacs")
+    (description"\
+This package provides a consistent ESS-like evaluation interface for
+Python REPLs.  Emacs Speaks Statistics (ESS) package has a nice function
+called @code{ess-eval-region-or-line-and-step}, which is assigned to
+C-RET.  This function sends a line or a selected region to the corresponding
+shell (R, Julia, Stata, etc) visibly.  It also start up a shell if there is
 none.")
     (license license:expat)))
 (define-public emacs-eval-sexp-fu-el