diff mbox series

[bug#57737,08/22] gnu: Add emacs-eval-in-repl-hy.

Message ID 20220911181611.4171-8-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#57737,01/22] gnu: Add emacs-eval-in-repl. | expand

Commit Message

Nicolas Graves Sept. 11, 2022, 6:15 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-eval-in-repl-hy): New variable.
---
 gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b58fcf1c50..0c50cfdcb7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27242,6 +27242,32 @@  (define-public emacs-eval-in-repl-scheme
 called @code{ess-eval-region-or-line-and-step}, which is assigned to
 C-RET.  This function sends a line or a selected region to the corresponding
 shell (R, Julia, Stata, etc) visibly.  It also start up a shell if there is
+none.")
+    (license license:expat)))
+
+(define-public emacs-eval-in-repl-hy
+  (package
+    (name "emacs-eval-in-repl-hy")
+    (version "0.9.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://raw.githubusercontent.com/kaz-yos/eval-in-repl/"
+               version "/eval-in-repl-hy.el"))
+       (sha256
+          (base32
+           "1fcf2a6vrmwvd2blh97mfdrzmym2g6q0b63s51p1k5gw7ijz0i4r"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-eval-in-repl emacs-hy-mode))
+    (home-page "https://github.com/kaz-yos/eval-in-repl")
+    (synopsis "Consistent evaluation interface for Hy REPLs for emacs")
+    (description"\
+This package provides a consistent ESS-like evaluation interface for
+Hy REPLs.  Emacs Speaks Statistics (ESS) package has a nice function
+called @code{ess-eval-region-or-line-and-step}, which is assigned to
+C-RET.  This function sends a line or a selected region to the corresponding
+shell (R, Julia, Stata, etc) visibly.  It also start up a shell if there is
 none.")
     (license license:expat)))
 (define-public emacs-eval-sexp-fu-el