diff mbox series

[bug#57737,06/22] gnu: Add emacs-eval-in-repl-racket.

Message ID 20220911181611.4171-6-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#57737,01/22] gnu: Add emacs-eval-in-repl. | expand

Commit Message

Nicolas Graves Sept. 11, 2022, 6:15 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-eval-in-repl-racket): New variable.
---
 gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index baee5851a8..20f4553902 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27192,6 +27192,32 @@  (define-public emacs-eval-in-repl-geiser
 function sends a line or a selected region to the corresponding shell (R,
 Julia, Stata, etc) visibly.  It also start up a shell if there is none.")
     (license license:expat)))
+
+(define-public emacs-eval-in-repl-racket
+  (package
+    (name "emacs-eval-in-repl-racket")
+    (version "0.9.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://raw.githubusercontent.com/kaz-yos/eval-in-repl/"
+               version "/eval-in-repl-racket.el"))
+       (sha256
+          (base32
+           "0wpkig2z2vfyv08i444fi2yhjy2mk0la8mpyg0z6zywjm19kyir3"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-eval-in-repl emacs-racket-mode))
+    (home-page "https://github.com/kaz-yos/eval-in-repl")
+    (synopsis "Consistent evaluation interface for Racket REPLs for emacs")
+    (description"\
+This package provides a consistent ESS-like evaluation interface for
+Racket REPLs.  Emacs Speaks Statistics (ESS) package has a nice function
+called @code{ess-eval-region-or-line-and-step}, which is assigned to
+C-RET.  This function sends a line or a selected region to the corresponding
+shell (R, Julia, Stata, etc) visibly.  It also start up a shell if there is
+none.")
+    (license license:expat)))
 (define-public emacs-eval-sexp-fu-el
   (package
     (name "emacs-eval-sexp-fu-el")