diff mbox series

[bug#57737,12/22] gnu: Add emacs-eval-in-repl-ocaml.

Message ID 20220911181611.4171-12-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#57737,01/22] gnu: Add emacs-eval-in-repl. | expand

Commit Message

Nicolas Graves Sept. 11, 2022, 6:16 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-eval-in-repl-ocaml): New variable.
---
 gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7ba5ea262b..d95b2f2e20 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -239,6 +239,7 @@  (define-module (gnu packages emacs-xyz)
   #:use-module (gnu packages photo)
   #:use-module (gnu packages uml)
   #:use-module (gnu packages finance)
+  #:use-module (gnu packages ocaml)
   #:use-module (guix utils)
   #:use-module (srfi srfi-1)
   #:use-module (ice-9 match))
@@ -27346,6 +27347,32 @@  (define-public emacs-eval-in-repl-sml
 called @code{ess-eval-region-or-line-and-step}, which is assigned to
 C-RET.  This function sends a line or a selected region to the corresponding
 shell (R, Julia, Stata, etc) visibly.  It also start up a shell if there is
+none.")
+    (license license:expat)))
+
+(define-public emacs-eval-in-repl-ocaml
+  (package
+    (name "emacs-eval-in-repl-ocaml")
+    (version "0.9.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://raw.githubusercontent.com/kaz-yos/eval-in-repl/"
+             version "/eval-in-repl-ocaml.el"))
+       (sha256
+        (base32
+         "0y36x59adjf87ypfj62rrhdf6lg8qxyahvx9f7p1svblhryg7fr0"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-eval-in-repl emacs-tuareg))
+    (home-page "https://github.com/kaz-yos/eval-in-repl")
+    (synopsis "Consistent evaluation interface for OCaml REPLs for emacs")
+    (description"\
+This package provides a consistent ESS-like evaluation interface for
+OCaml REPLs.  Emacs Speaks Statistics (ESS) package has a nice function
+called @code{ess-eval-region-or-line-and-step}, which is assigned to
+C-RET.  This function sends a line or a selected region to the corresponding
+shell (R, Julia, Stata, etc) visibly.  It also start up a shell if there is
 none.")
     (license license:expat)))
 (define-public emacs-eval-sexp-fu-el