diff mbox series

[bug#57737,04/22] gnu: Add emacs-eval-in-repl-slime.

Message ID 20220911181611.4171-4-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#57737,01/22] gnu: Add emacs-eval-in-repl. | expand

Commit Message

Nicolas Graves Sept. 11, 2022, 6:15 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-eval-in-repl-slime): New variable.
---
 gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index fad450fb25..26ba6f2c85 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27138,6 +27138,32 @@  (define-public emacs-eval-in-repl-cider
 called @code{ess-eval-region-or-line-and-step}, which is assigned to
 C-RET.  This function sends a line or a selected region to the corresponding
 shell (R, Julia, Stata, etc) visibly.  It also start up a shell if there is
+none.")
+    (license license:expat)))
+
+(define-public emacs-eval-in-repl-slime
+  (package
+    (name "emacs-eval-in-repl-slime")
+    (version "0.9.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://raw.githubusercontent.com/kaz-yos/eval-in-repl/"
+               version "/eval-in-repl-slime.el"))
+       (sha256
+          (base32
+           "0qj4dkkkf1xgvcy6wz537w5d2aqnwc75w8g9qzdsfyadaiycgrsd"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-eval-in-repl emacs-slime))
+    (home-page "https://github.com/kaz-yos/eval-in-repl")
+    (synopsis "Consistent evaluation interface for Common Lisp REPLs for emacs")
+    (description"\
+This package provides a consistent ESS-like evaluation interface for
+Common Lisp REPLs.  Emacs Speaks Statistics (ESS) package has a nice function
+called @code{ess-eval-region-or-line-and-step}, which is assigned to
+C-RET.  This function sends a line or a selected region to the corresponding
+shell (R, Julia, Stata, etc) visibly.  It also start up a shell if there is
 none.")
     (license license:expat)))
 (define-public emacs-eval-sexp-fu-el