diff mbox series

[bug#54299,05/27] added rust-dlib@0.5

Message ID 20220308173127.21218-4-trzickel@illegalaliensfrom.space
State New
Headers show
Series None | expand

Commit Message

Till Robin Zickel March 8, 2022, 5:31 p.m. UTC
---
 gnu/packages/crates-io.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)

Comments

M March 8, 2022, 6:08 p.m. UTC | #1
Till Robin Zickel schreef op di 08-03-2022 om 18:31 [+0100]:
> +     `(#:tests? #f

Why?
M March 8, 2022, 6:09 p.m. UTC | #2
Till Robin Zickel schreef op di 08-03-2022 om 18:31 [+0100]:
> +       #:cargo-inputs
> +       (("rust-libloading" ,rust-libloading-0.7))))
> +    (inputs (list rust-libloading-0.7))))

Why both #:cargo-inputs and 'inputs'?
M March 21, 2022, 6:50 p.m. UTC | #3
Till Robin Zickel schreef op zo 20-03-2022 om 22:07 [+0100]:
> The crate presumably needs a directory which isn't present in the 
> downloaded source archive, thus the tests will fail. This was the case 
> with other packages, so I copied the strategy of not running the tests.

Then those packages should be fixed (not a requirement for this patch
series though).

In any case, presumably you can find the missing directory in the git
repository, so maybe a git-reference can be used to resolve the issue?

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 54fc4e64ff..9de962d5c3 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -18467,6 +18467,24 @@  (define-public rust-dlib-0.4
 system libraries.")
     (license license:expat)))
 
+(define-public rust-dlib-0.5
+  (package
+    (inherit rust-dlib-0.4)
+    (name "rust-dlib")
+    (version "0.5.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "dlib" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1547hy7nrhkrb2i09va244c0h8mr845ccbs2d2mc414c68bpa6xc"))))
+    (arguments
+     `(#:tests? #f
+       #:cargo-inputs
+       (("rust-libloading" ,rust-libloading-0.7))))
+    (inputs (list rust-libloading-0.7))))
+
 (define-public rust-dlv-list-0.2
   (package
     (name "rust-dlv-list")