diff mbox series

[bug#54299,14/27] added rust-glutin@0.28

Message ID 20220308173127.21218-13-trzickel@illegalaliensfrom.space
State New
Headers show
Series None | expand

Commit Message

Till Robin Zickel March 8, 2022, 5:31 p.m. UTC
---
 gnu/packages/crates-graphics.scm | 34 ++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

Comments

M March 8, 2022, 5:57 p.m. UTC | #1
Till Robin Zickel schreef op di 08-03-2022 om 18:31 [+0100]:
> +     `(#:skip-build? #t
Why?

> +       #:cargo-inputs
> +       (("rust-android-glue" ,rust-android-glue-0.2) ("rust-cgl" ,rust-cgl-0.3)

Would regular inputs suffice?
M March 8, 2022, 5:58 p.m. UTC | #2
Till Robin Zickel schreef op di 08-03-2022 om 18:31 [+0100]:
> +        ("rust-winapi" ,rust-winapi-0.3)
> +        ("rust-winit" ,rust-winit-0.26))))

Microsoft Windows is currently not supported in Guix (except
for some mingw cross-compilation, but that probably doesn't cover Rust
yet).  Please remove them.
M March 8, 2022, 5:58 p.m. UTC | #3
Till Robin Zickel schreef op di 08-03-2022 om 18:31 [+0100]:
> +       (("rust-android-glue" ,rust-android-glue-0.2) ("rust-cgl" ,rust-cgl-0.3)
> +        ("rust-cocoa" ,rust-cocoa-0.24)
> +        ("rust-core-foundation" ,rust-core-foundation-0.9)

Android and whatever the name is for Apple's OS are currently
unsupported in Guix, so these inputs seem pointless to me.
diff mbox series

Patch

diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index d1a9c4dd6d..71bb620b18 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -1005,6 +1005,40 @@  (define-public rust-glutin-0.26
     (description "This package provides an OpenGL context provider.")
     (license license:asl2.0)))
 
+(define-public rust-glutin-0.28
+  (package
+    (inherit rust-glutin-0.26)
+    (name "rust-glutin")
+    (version "0.28.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "glutin" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1lpnf61x4jbm55bpdr10k1a1pl3cs719i9y4qibsdj2bajz9vsh0"))))
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-android-glue" ,rust-android-glue-0.2) ("rust-cgl" ,rust-cgl-0.3)
+        ("rust-cocoa" ,rust-cocoa-0.24)
+        ("rust-core-foundation" ,rust-core-foundation-0.9)
+        ("rust-glutin-egl-sys" ,rust-glutin-egl-sys-0.1)
+        ("rust-glutin-emscripten-sys" ,rust-glutin-emscripten-sys-0.1)
+        ("rust-glutin-gles2-sys" ,rust-glutin-gles2-sys-0.1)
+        ("rust-glutin-glx-sys" ,rust-glutin-glx-sys-0.1)
+        ("rust-glutin-wgl-sys" ,rust-glutin-wgl-sys-0.1)
+        ("rust-lazy-static" ,rust-lazy-static-1)
+        ("rust-libloading" ,rust-libloading-0.6)
+        ("rust-log" ,rust-log-0.4)
+        ("rust-objc" ,rust-objc-0.2)
+        ("rust-osmesa-sys" ,rust-osmesa-sys-0.1)
+        ("rust-parking-lot" ,rust-parking-lot-0.11)
+        ("rust-wayland-egl" ,rust-wayland-egl-0.29)
+        ("rust-winapi" ,rust-winapi-0.3)
+        ("rust-winit" ,rust-winit-0.26))))
+    (inputs (list rust-wayland-client-0.29 rust-wayland-egl-0.29))))
+
 (define-public rust-glutin-0.22
   (package
     (inherit rust-glutin-0.26)