diff mbox series

[bug#54299,16/27] added rust-raw-window-handle@0.4

Message ID 20220308173127.21218-15-trzickel@illegalaliensfrom.space
State New
Headers show
Series None | expand

Commit Message

Till Robin Zickel March 8, 2022, 5:31 p.m. UTC
---
 gnu/packages/crates-graphics.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)

Comments

M March 8, 2022, 5:56 p.m. UTC | #1
Till Robin Zickel schreef op di 08-03-2022 om 18:31 [+0100]:
> +    (arguments
> +     `(#:skip-build? #t

Why? (see some of my other replies on other patches)

> +       #:cargo-inputs
> +       (("rust-cty" ,rust-cty-0.2))))))

Would regular inputs suffice, instead of the cargo-specific hack?
diff mbox series

Patch

diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 9261f6f6ae..2d87ea1c64 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -2139,6 +2139,23 @@  (define-public rust-raw-window-handle-0.3
      "Interoperability library for Rust Windowing applications.")
     (license license:expat)))
 
+(define-public rust-raw-window-handle-0.4
+  (package
+    (inherit rust-raw-window-handle-0.3)
+    (name "rust-raw-window-handle")
+    (version "0.4.2")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "raw-window-handle" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1dr24lzairc9hdw2a8sk03vixzngv42y3qf9d0x2gmd9jkp5x9zv"))))
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-cty" ,rust-cty-0.2))))))
+
 (define-public rust-resize-0.3
   (package
     (name "rust-resize")