diff mbox series

[bug#54299,19/27] added rust-wayland-client@0.29

Message ID 20220308173127.21218-18-trzickel@illegalaliensfrom.space
State New
Headers show
Series None | expand

Commit Message

Till Robin Zickel March 8, 2022, 5:31 p.m. UTC
---
 gnu/packages/crates-graphics.scm | 33 ++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

M March 8, 2022, 5:56 p.m. UTC | #1
Till Robin Zickel schreef op di 08-03-2022 om 18:31 [+0100]:
> +     `(#:skip-build? #t

Why?  From (guix)Rust Crates:

   Care should be taken to ensure the correct version of dependencies
are used; to this end we try to refrain from skipping the tests or using
‘#:skip-build?’ when possible.  Of course this is not always possible,
as the package may be developed for a different Operating System, depend
on features from the Nightly Rust compiler, or the test suite may have
atrophied since it was released.

An additional reason is that we want to eventually always re-use pre-compiled
inputs, though AFAICT this is currently not (not always?) possible.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 502a62fcd6..e9f3bcd778 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -2505,6 +2505,39 @@  (define-public rust-wayland-client-0.28
 the wayland protocol, client side.")
     (license license:expat)))
 
+(define-public rust-wayland-client-0.29
+  (package
+    (inherit rust-wayland-client-0.28)
+    (name "rust-wayland-client")
+    (version "0.29.4")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "wayland-client" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "13s5sj9344izk2g48yizk81kcg8jg4940gg2v6bzcmrjwxh388li"))))
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-bitflags" ,rust-bitflags-1) ("rust-downcast-rs" ,rust-downcast-rs-1)
+        ("rust-libc" ,rust-libc-0.2)
+        ("rust-nix" ,rust-nix-0.22)
+        ("rust-scoped-tls" ,rust-scoped-tls-1)
+        ("rust-wayland-commons" ,rust-wayland-commons-0.29)
+        ("rust-wayland-scanner" ,rust-wayland-scanner-0.29)
+        ("rust-wayland-sys" ,rust-wayland-sys-0.29))
+       #:cargo-development-inputs
+       (("rust-tempfile" ,rust-tempfile-3))))
+    (inputs (list rust-bitflags-1
+                  rust-downcast-rs-1
+                  rust-libc-0.2
+                  rust-nix-0.22
+                  rust-scoped-tls-1
+                  rust-wayland-commons-0.29
+                  rust-wayland-scanner-0.29
+                  rust-wayland-sys-0.29))))
+
 (define-public rust-wayland-client-0.23
   (package
     (inherit rust-wayland-client-0.28)