diff mbox series

[bug#54299,24/27] added rust-wayland-scanner@0.29

Message ID 20220308173127.21218-23-trzickel@illegalaliensfrom.space
State New
Headers show
Series None | expand

Commit Message

Till Robin Zickel March 8, 2022, 5:31 p.m. UTC
---
 gnu/packages/crates-graphics.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)

Comments

M March 8, 2022, 5:52 p.m. UTC | #1
Till Robin Zickel schreef op di 08-03-2022 om 18:31 [+0100]:
> +(define-public rust-wayland-scanner-0.29
> +  (package
> +    (inherit rust-wayland-scanner-0.28)
> +    (name "rust-wayland-scanner")
> +    (version "0.29.4")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (crate-uri "wayland-scanner" version))
> +              (file-name (string-append name "-" version ".tar.gz"))
> +              (sha256
> +               (base32
> +                "1q7r764z8k922xf51fj56b1xm29ffi9ap8jnf4c478gp8cqyv89r"))))))

Is 0.29 backwards compatible with 0.28?  If so, perhaps we could just
update rust-wayland-scanner and point rust packages to the new rust-
wayland-scanner?
diff mbox series

Patch

diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 91ea39c212..ef843affb3 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -2880,6 +2880,20 @@  (define-public rust-wayland-scanner-0.28
 wayland-client crate for usable bindings.")
     (license license:expat)))
 
+(define-public rust-wayland-scanner-0.29
+  (package
+    (inherit rust-wayland-scanner-0.28)
+    (name "rust-wayland-scanner")
+    (version "0.29.4")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "wayland-scanner" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1q7r764z8k922xf51fj56b1xm29ffi9ap8jnf4c478gp8cqyv89r"))))))
+
+
 (define-public rust-wayland-scanner-0.23
   (package
     (inherit rust-wayland-scanner-0.28)