diff mbox series

[bug#49993,03/18] gnu: Remove python2-jsonschema.

Message ID 20210811030901.2865-3-ben@sturm.com.au
State New
Headers show
Series Remove Python 2 packages possibly added for Python 2 MediaGoblin. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Ben Sturmfels Aug. 11, 2021, 3:08 a.m. UTC
Remove Python 2 leaf package possibly added for Python 2 MediaGoblin.

* gnu/packages/python-xyz.scm (python2-jsonschema): Remove variable.
---
 gnu/packages/python-xyz.scm | 11 +----------
 1 file changed, 1 insertion(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 54e37df21f..291a5c50fc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3368,16 +3368,7 @@  compare, diff, and patch JSON and JSON-like structures in Python.")
     (synopsis "Implementation of JSON Schema for Python")
     (description
      "Jsonschema is an implementation of JSON Schema for Python.")
-    (license license:expat)
-    (properties `((python2-variant . ,(delay python2-jsonschema))))))
-
-(define-public python2-jsonschema
-  (let ((jsonschema (package-with-python2
-                     (strip-python2-variant python-jsonschema))))
-    (package/inherit jsonschema
-             (propagated-inputs
-              `(("python2-functools32" ,python2-functools32)
-                ,@(package-propagated-inputs jsonschema))))))
+    (license license:expat)))
 
 (define-public python-schema
   (package