diff mbox series

[bug#49993,17/18] gnu: Remove python2-openid.

Message ID 20210811030901.2865-17-ben@sturm.com.au
State New
Headers show
Series Remove Python 2 packages possibly added for Python 2 MediaGoblin. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Ben Sturmfels Aug. 11, 2021, 3:09 a.m. UTC
Remove Python 2 leaf package possibly added for Python 2 MediaGoblin.

* gnu/packages/python-web.scm (python2-openid): Remove variable.
---
 gnu/packages/python-web.scm | 24 ------------------------
 1 file changed, 24 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f3589dc06c..214bc90127 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1331,7 +1331,6 @@  is Python’s.")
           (lambda _
             (invoke "coverage" "run" "-m"
                     "unittest" "openid.test.test_suite"))))))
-    (properties `((python2-variant . ,(delay python2-openid))))
     (propagated-inputs
      `(("python-defusedxml" ,python-defusedxml)))
     (native-inputs
@@ -1344,29 +1343,6 @@  is Python’s.")
 for clients and servers.")
     (license license:asl2.0)))
 
-(define-public python2-openid
-  (package
-    (name "python2-openid")
-    (version "2.2.5")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "python-openid" version))
-       (sha256
-        (base32
-         "1vvhxlghjan01snfdc4k7ykd80vkyjgizwgg9bncnin8rqz1ricj"))))
-    (build-system python-build-system)
-    (arguments
-     ;; Python 3 support is in `python3-openid`, a separate package.
-     `(#:python ,python-2
-       ;; Tests aren't initialized correctly.
-       #:tests? #f))
-    (home-page "https://github.com/openid/python-openid")
-    (synopsis "OpenID support for servers and consumers")
-    (description "This library provides OpenID authentication for Python, both
-for clients and servers.")
-    (license license:asl2.0)))
-
 (define-public python-cssutils
   (package
     (name "python-cssutils")