diff mbox series

[bug#49662,v1,5/5] gnu: weston: Propagate some inputs as per pkg-config files.

Message ID 20210720143657.31826-5-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#49662,v1,1/5] gnu: weston: Update to 9.0.0 and adjust arguments+inputs accordingly. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan July 20, 2021, 2:36 p.m. UTC
* gnu/packages/freedesktop.scm (weston)[inputs]: Move libxkbcommon,
pixman and wayland to ...
[propagated-inputs]: ... here.
---
 gnu/packages/freedesktop.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

Comments

Efraim Flashner July 20, 2021, 6:25 p.m. UTC | #1
On Tue, Jul 20, 2021 at 10:36:57AM -0400, Raghav Gururajan via Guix-patches via wrote:
> * gnu/packages/freedesktop.scm (weston)[inputs]: Move libxkbcommon,
> pixman and wayland to ...
> [propagated-inputs]: ... here.
> ---

you added pixman in a previous patch. I would combine the two patches
for adding more inputs and moving others to propagated-inputs with a
'fixup package inputs' or a subject line similar to that.

>  gnu/packages/freedesktop.scm | 7 ++++---
>  1 file changed, 4 insertions(+), 3 deletions(-)
> 
> diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
> index f05b5927f9..401d15a2df 100644
> --- a/gnu/packages/freedesktop.scm
> +++ b/gnu/packages/freedesktop.scm
> @@ -1074,17 +1074,18 @@ applications, X servers (rootless or fullscreen) or other display servers.")
>         ("libx11" ,libx11)
>         ("libxcb" ,libxcb)
>         ("libxcursor" ,libxcursor)
> -       ("libxkbcommon" ,libxkbcommon)
>         ("libxml2" ,libxml2)
>         ("mesa" ,mesa)
>         ("mtdev" ,mtdev)
>         ("linux-pam" ,linux-pam)
>         ("pango" ,pango)
>         ("pipewire" ,pipewire)
> -       ("pixman" ,pixman)
> -       ("wayland" ,wayland)
>         ("wayland-protocols" ,wayland-protocols)
>         ("xorg-server-xwayland" ,xorg-server-xwayland)))
> +    (propagated-inputs
> +     `(("libxkbcommon" ,libxkbcommon)
> +       ("pixman" ,pixman)
> +       ("wayland" ,wayland)))
>      (arguments
>       `(#:configure-flags
>         (list
> -- 
> 2.32.0
> 
> 
> 
>
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index f05b5927f9..401d15a2df 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1074,17 +1074,18 @@  applications, X servers (rootless or fullscreen) or other display servers.")
        ("libx11" ,libx11)
        ("libxcb" ,libxcb)
        ("libxcursor" ,libxcursor)
-       ("libxkbcommon" ,libxkbcommon)
        ("libxml2" ,libxml2)
        ("mesa" ,mesa)
        ("mtdev" ,mtdev)
        ("linux-pam" ,linux-pam)
        ("pango" ,pango)
        ("pipewire" ,pipewire)
-       ("pixman" ,pixman)
-       ("wayland" ,wayland)
        ("wayland-protocols" ,wayland-protocols)
        ("xorg-server-xwayland" ,xorg-server-xwayland)))
+    (propagated-inputs
+     `(("libxkbcommon" ,libxkbcommon)
+       ("pixman" ,pixman)
+       ("wayland" ,wayland)))
     (arguments
      `(#:configure-flags
        (list