diff mbox series

[bug#49662,v1,1/5] gnu: weston: Update to 9.0.0 and adjust arguments+inputs accordingly.

Message ID 20210720143657.31826-1-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#49662,v1,1/5] gnu: weston: Update to 9.0.0 and adjust arguments+inputs accordingly. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan July 20, 2021, 2:36 p.m. UTC
* gnu/packages/freedesktop.scm (weston)[version]: Update to 9.0.0.
[configure-flags](c_link_args): New flag.
(simple-dmabuf-drm): Remove flag.
[native-inputs]: Add mscgen.
[inputs]: Add pipewire.
---
 gnu/packages/freedesktop.scm | 30 +++++++++++++++++++-----------
 1 file changed, 19 insertions(+), 11 deletions(-)

Comments

Efraim Flashner July 20, 2021, 6:27 p.m. UTC | #1
On Tue, Jul 20, 2021 at 10:36:53AM -0400, Raghav Gururajan via Guix-patches via wrote:
> * gnu/packages/freedesktop.scm (weston)[version]: Update to 9.0.0.
> [configure-flags](c_link_args): New flag.
> (simple-dmabuf-drm): Remove flag.
> [native-inputs]: Add mscgen.
> [inputs]: Add pipewire.
> ---
>  gnu/packages/freedesktop.scm | 30 +++++++++++++++++++-----------
>  1 file changed, 19 insertions(+), 11 deletions(-)
> 
> diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
> index 24f12a045a..c59efa67b4 100644
> --- a/gnu/packages/freedesktop.scm
> +++ b/gnu/packages/freedesktop.scm
> @@ -75,6 +75,7 @@
>    #:use-module (gnu packages glib)                ;intltool
>    #:use-module (gnu packages gnome)
>    #:use-module (gnu packages gperf)
> +  #:use-module (gnu packages graph)
>    #:use-module (gnu packages graphviz)
>    #:use-module (gnu packages gstreamer)
>    #:use-module (gnu packages gtk)
> @@ -1037,7 +1038,7 @@ applications, X servers (rootless or fullscreen) or other display servers.")
>  (define-public weston
>    (package
>      (name "weston")
> -    (version "6.0.1")
> +    (version "9.0.0")
>      (source (origin
>                (method url-fetch)
>                (uri (string-append
> @@ -1045,10 +1046,11 @@ applications, X servers (rootless or fullscreen) or other display servers.")
>                      "weston-" version ".tar.xz"))
>                (sha256
>                 (base32
> -                "1d2m658ll8x7prlsfk71qgw89c7dz6y7d6nndfxwl49fmrd6sbxz"))))
> +                "1zlql0xgiqc3pvgbpnnvj4xvpd91pwva8qf83xfb23if377ddxaw"))))
>      (build-system meson-build-system)
>      (native-inputs
> -     `(("pkg-config" ,pkg-config)
> +     `(("mscgen" ,mscgen)
> +       ("pkg-config" ,pkg-config)
>         ("xorg-server" ,xorg-server)))
>      (inputs
>       `(("cairo" ,cairo-xcb)
> @@ -1069,19 +1071,25 @@ applications, X servers (rootless or fullscreen) or other display servers.")
>         ("mtdev" ,mtdev)
>         ("linux-pam" ,linux-pam)
>         ("pango" ,pango)
> +       ("pipewire" ,pipewire)
>         ("wayland" ,wayland)
>         ("wayland-protocols" ,wayland-protocols)
>         ("xorg-server-xwayland" ,xorg-server-xwayland)))
>      (arguments
>       `(#:configure-flags
> -       (list "-Dbackend-rdp=false" ; TODO: Enable.
> -             "-Dremoting=false" ; TODO: Enable.
> -             "-Dsimple-dmabuf-drm=auto"
> -             "-Dsystemd=false"
> -             (string-append "-Dxwayland-path="
> -                            (assoc-ref %build-inputs "xorg-server-xwayland")
> -                            "/bin/Xwayland"))
> -       #:parallel-tests? #f ; Parallel tests cause failures.
> +       (list
> +        ;; Otherwise, the RUNPATH will lack the final path component.
> +        (string-append "-Dc_link_args=-Wl,-rpath="
> +                       (assoc-ref %outputs "out") "/lib:"
> +                       (assoc-ref %outputs "out") "/lib/weston:"
> +                       (assoc-ref %outputs "out") "/lib/libweston-9")

rather (untested):
(assoc-ref %outputs "out") "/lib/libweston-" (version-major ,version))

> +        "-Dbackend-rdp=false"           ; TODO: Enable.
> +        "-Dremoting=false"              ; TODO: Enable.
> +        "-Dsystemd=false"
> +        (string-append "-Dxwayland-path="
> +                       (assoc-ref %build-inputs "xorg-server-xwayland")
> +                       "/bin/Xwayland"))
> +       #:parallel-tests? #f           ; Parallel tests cause failures.
>         #:phases
>         (modify-phases %standard-phases
>           (add-before 'configure 'use-elogind
> -- 
> 2.32.0
> 
> 
> 
>
Sarah Morgensen July 21, 2021, 7:30 p.m. UTC | #2
Efraim Flashner <efraim@flashner.co.il> writes:

[...]

>> +                       (assoc-ref %outputs "out") "/lib:"
>> +                       (assoc-ref %outputs "out") "/lib/weston:"
>> +                       (assoc-ref %outputs "out") "/lib/libweston-9")
>
> rather (untested):
> (assoc-ref %outputs "out") "/lib/libweston-" (version-major ,version))

Or perhaps more robustly (in case of inheritance):
  (assoc-ref %outputs "out") "/lib/libweston-" (version-major
                                               ,(package-version this-package))

--
Sarah
Efraim Flashner July 22, 2021, 6:34 a.m. UTC | #3
On Wed, Jul 21, 2021 at 12:30:29PM -0700, Sarah Morgensen wrote:
> Efraim Flashner <efraim@flashner.co.il> writes:
> 
> [...]
> 
> >> +                       (assoc-ref %outputs "out") "/lib:"
> >> +                       (assoc-ref %outputs "out") "/lib/weston:"
> >> +                       (assoc-ref %outputs "out") "/lib/libweston-9")
> >
> > rather (untested):
> > (assoc-ref %outputs "out") "/lib/libweston-" (version-major ,version))
> 
> Or perhaps more robustly (in case of inheritance):
>   (assoc-ref %outputs "out") "/lib/libweston-" (version-major
>                                                ,(package-version this-package))
> 

That is nicer. I should get more used to using this-package.
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 24f12a045a..c59efa67b4 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -75,6 +75,7 @@ 
   #:use-module (gnu packages glib)                ;intltool
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gperf)
+  #:use-module (gnu packages graph)
   #:use-module (gnu packages graphviz)
   #:use-module (gnu packages gstreamer)
   #:use-module (gnu packages gtk)
@@ -1037,7 +1038,7 @@  applications, X servers (rootless or fullscreen) or other display servers.")
 (define-public weston
   (package
     (name "weston")
-    (version "6.0.1")
+    (version "9.0.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -1045,10 +1046,11 @@  applications, X servers (rootless or fullscreen) or other display servers.")
                     "weston-" version ".tar.xz"))
               (sha256
                (base32
-                "1d2m658ll8x7prlsfk71qgw89c7dz6y7d6nndfxwl49fmrd6sbxz"))))
+                "1zlql0xgiqc3pvgbpnnvj4xvpd91pwva8qf83xfb23if377ddxaw"))))
     (build-system meson-build-system)
     (native-inputs
-     `(("pkg-config" ,pkg-config)
+     `(("mscgen" ,mscgen)
+       ("pkg-config" ,pkg-config)
        ("xorg-server" ,xorg-server)))
     (inputs
      `(("cairo" ,cairo-xcb)
@@ -1069,19 +1071,25 @@  applications, X servers (rootless or fullscreen) or other display servers.")
        ("mtdev" ,mtdev)
        ("linux-pam" ,linux-pam)
        ("pango" ,pango)
+       ("pipewire" ,pipewire)
        ("wayland" ,wayland)
        ("wayland-protocols" ,wayland-protocols)
        ("xorg-server-xwayland" ,xorg-server-xwayland)))
     (arguments
      `(#:configure-flags
-       (list "-Dbackend-rdp=false" ; TODO: Enable.
-             "-Dremoting=false" ; TODO: Enable.
-             "-Dsimple-dmabuf-drm=auto"
-             "-Dsystemd=false"
-             (string-append "-Dxwayland-path="
-                            (assoc-ref %build-inputs "xorg-server-xwayland")
-                            "/bin/Xwayland"))
-       #:parallel-tests? #f ; Parallel tests cause failures.
+       (list
+        ;; Otherwise, the RUNPATH will lack the final path component.
+        (string-append "-Dc_link_args=-Wl,-rpath="
+                       (assoc-ref %outputs "out") "/lib:"
+                       (assoc-ref %outputs "out") "/lib/weston:"
+                       (assoc-ref %outputs "out") "/lib/libweston-9")
+        "-Dbackend-rdp=false"           ; TODO: Enable.
+        "-Dremoting=false"              ; TODO: Enable.
+        "-Dsystemd=false"
+        (string-append "-Dxwayland-path="
+                       (assoc-ref %build-inputs "xorg-server-xwayland")
+                       "/bin/Xwayland"))
+       #:parallel-tests? #f           ; Parallel tests cause failures.
        #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'use-elogind