diff mbox series

[bug#49662,v1,4/5] gnu: weston: Enable some features.

Message ID 20210720143657.31826-4-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#49662,v1,1/5] gnu: weston: Update to 9.0.0 and adjust arguments+inputs accordingly. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan July 20, 2021, 2:36 p.m. UTC
* gnu/packages/freedesktop.scm (weston)[inputs]: Add freerdp,
gstreamer and gst-plugins-base.
[configure-flags](backend-rdp,remoting): Remove flags.
(backend-default): New flag.
---
 gnu/packages/freedesktop.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index a6e96dc500..f05b5927f9 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -97,6 +97,7 @@ 
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-crypto)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages rdesktop)
   #:use-module (gnu packages samba)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages valgrind)
@@ -1057,7 +1058,10 @@  applications, X servers (rootless or fullscreen) or other display servers.")
        ("colord" ,colord)
        ("dbus" ,dbus)
        ("elogind" ,elogind)
+       ("freerdp" ,freerdp)
        ("glib" ,glib)
+       ("gstreamer" ,gstreamer)
+       ("gst-plugins-base" ,gst-plugins-base)
        ("lcms" ,lcms)
        ("libdrm" ,libdrm)
        ("libevdev" ,libevdev)
@@ -1089,8 +1093,7 @@  applications, X servers (rootless or fullscreen) or other display servers.")
                        (assoc-ref %outputs "out") "/lib:"
                        (assoc-ref %outputs "out") "/lib/weston:"
                        (assoc-ref %outputs "out") "/lib/libweston-9")
-        "-Dbackend-rdp=false"           ; TODO: Enable.
-        "-Dremoting=false"              ; TODO: Enable.
+        "-Dbackend-default=auto"
         "-Dsystemd=false"
         (string-append "-Dxwayland-path="
                        (assoc-ref %build-inputs "xorg-server-xwayland")