diff mbox series

[bug#49662,v1,2/5] gnu: weston: Add missing inputs.

Message ID 20210720143657.31826-2-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#49662,v1,1/5] gnu: weston: Update to 9.0.0 and adjust arguments+inputs accordingly. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan July 20, 2021, 2:36 p.m. UTC
These new inputs are referenced by the package but was missing in
the package definition. Some of these inputs might have been used
by the package indirectly via propagation from other inputs.

* gnu/packages/freedesktop.scm (weston)[inputs]: Add glib, libdrm,
libpng, libx11, libxcb and pixman.
---
 gnu/packages/freedesktop.scm | 6 ++++++
 1 file changed, 6 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index c59efa67b4..a6e96dc500 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1057,13 +1057,18 @@  applications, X servers (rootless or fullscreen) or other display servers.")
        ("colord" ,colord)
        ("dbus" ,dbus)
        ("elogind" ,elogind)
+       ("glib" ,glib)
        ("lcms" ,lcms)
+       ("libdrm" ,libdrm)
        ("libevdev" ,libevdev)
        ("libinput" ,libinput-minimal)
        ("libjpeg" ,libjpeg-turbo)
+       ("libpng" ,libpng)
        ("libunwind" ,libunwind)
        ("libva" ,libva)
        ("libwebp" ,libwebp)
+       ("libx11" ,libx11)
+       ("libxcb" ,libxcb)
        ("libxcursor" ,libxcursor)
        ("libxkbcommon" ,libxkbcommon)
        ("libxml2" ,libxml2)
@@ -1072,6 +1077,7 @@  applications, X servers (rootless or fullscreen) or other display servers.")
        ("linux-pam" ,linux-pam)
        ("pango" ,pango)
        ("pipewire" ,pipewire)
+       ("pixman" ,pixman)
        ("wayland" ,wayland)
        ("wayland-protocols" ,wayland-protocols)
        ("xorg-server-xwayland" ,xorg-server-xwayland)))