diff mbox series

[bug#49662,v1,3/5] gnu: freerdp: Propagate some inputs as per pkg-config files.

Message ID 20210720143657.31826-3-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#49662,v1,1/5] gnu: weston: Update to 9.0.0 and adjust arguments+inputs accordingly. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan July 20, 2021, 2:36 p.m. UTC
* gnu/packages/rdesktop.scm (freerdp)[inputs]: Move libxkbcommon,
openssl and wayland to ...
[propagated-inputs]: ... here.
---
 gnu/packages/rdesktop.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/rdesktop.scm b/gnu/packages/rdesktop.scm
index 30523deefe..adfbe7de06 100644
--- a/gnu/packages/rdesktop.scm
+++ b/gnu/packages/rdesktop.scm
@@ -108,7 +108,6 @@  to remotely control a user's Windows desktop.")
        ("libjpeg" ,libjpeg-turbo)
        ("libusb" ,libusb)
        ("libx11" ,libx11)
-       ("libxkbcommon" ,libxkbcommon)
        ("libxkbfile" ,libxkbfile)
        ("libxcursor" ,libxcursor)
        ("libxext" ,libxext)
@@ -118,10 +117,12 @@  to remotely control a user's Windows desktop.")
        ("libxrender" ,libxrender)
        ("libxinerama" ,libxinerama)
        ("libxshmfence" ,libxshmfence)
-       ("openssl" ,openssl)
        ("pulseaudio" ,pulseaudio)
-       ("wayland" ,wayland)
        ("zlib" ,zlib)))
+    (propagated-inputs
+     `(("libxkbcommon" ,libxkbcommon)
+       ("openssl" ,openssl)
+       ("wayland" ,wayland)))
     (arguments
      `(#:build-type "RELEASE"
        #:configure-flags