diff mbox series

[bug#37704,7/9] gnu: Add python-cachy.

Message ID 20191011164102.fakx7lr3b5xkkb2h@rafflesia
State Accepted
Headers show
Series gnu: Add python-poetry. | expand

Commit Message

Tanguy LE CARROUR Oct. 11, 2019, 4:41 p.m. UTC
From 63a97fc5ae9c60294594c7ae84ee025dfe695895 Mon Sep 17 00:00:00 2001
From: Tanguy Le Carrour <tanguy@bioneland.org>
Date: Wed, 9 Oct 2019 10:03:31 +0200
Subject: [PATCH 7/9] gnu: Add python-cachy.

---
 gnu/packages/python-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2e7b4937b8..5240f4d894 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10613,6 +10613,33 @@  command line interfaces.")
     (description "MessagePack (de)serializer.")
     (license license:asl2.0)))
 
+(define-public python-cachy
+  (package
+    (name "python-cachy")
+    (version "0.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "cachy" version))
+       (sha256
+        (base32
+         "0v6mjyhgx6j7ya20bk69cr3gdzdkdf6psay0h090rscclgji65dp"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-fakeredis" ,python-fakeredis)
+       ("python-flexmock" ,python-flexmock)
+       ("python-pytest" ,python-pytest)))
+    (propagated-inputs
+     `(("python-memcached" ,python-memcached)
+       ("python-msgpack-python" ,python-msgpack-python)
+       ("python-redis" ,python-redis)))
+    (home-page "https://github.com/sdispater/cachy")
+    (synopsis
+     "Cachy provides a simple yet effective caching library")
+    (description
+     "Cachy provides a simple yet effective caching library.")
+    (license license:expat)))
+
 (define-public python-lazy-object-proxy
   (package
     (name "python-lazy-object-proxy")