diff mbox series

[bug#37704,5/9] gnu: Add python-clikit.

Message ID 20191011164004.45oh6ug2eyzu3vvp@rafflesia
State Accepted
Headers show
Series gnu: Add python-poetry. | expand

Commit Message

Tanguy LE CARROUR Oct. 11, 2019, 4:40 p.m. UTC
From c529d63597220adb872e4dcc8232abae0fbee0a6 Mon Sep 17 00:00:00 2001
From: Tanguy Le Carrour <tanguy@bioneland.org>
Date: Wed, 9 Oct 2019 09:55:19 +0200
Subject: [PATCH 5/9] gnu: Add python-clikit.

---
 gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d02f7492a2..3c6611ef3f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10573,6 +10573,29 @@  docstring and colored output.")
     (description "Pure python memcached client")
     (license license:psfl)))
 
+(define-public python-clikit
+  (package
+    (name "python-clikit")
+    (version "0.2.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "clikit" version))
+       (sha256
+        (base32
+         "0dc8czib5f4j9px1ivcpqnmivnx2zjpc0xb00ldrhsqylks7r06n"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-pastel" ,python-pastel)
+       ("python-pylev" ,python-pylev)))
+    (home-page "https://github.com/sdispater/clikit")
+    (synopsis
+     "CliKit is a group of utilities to build command line interfaces")
+    (description
+     "CliKit is a group of utilities to build beautiful and testable
+command line interfaces.")
+    (license license:expat)))
+
 (define-public python-lazy-object-proxy
   (package
     (name "python-lazy-object-proxy")