diff mbox series

[bug#37704,3/9] gnu: Add python-shellingham.

Message ID 20191011163905.vpmsxqvjdxsqi3us@rafflesia
State Accepted
Headers show
Series gnu: Add python-poetry. | expand

Commit Message

Tanguy LE CARROUR Oct. 11, 2019, 4:39 p.m. UTC
From 21d5dc146d5ba3dd8ed2c20fbdf82843923af9ff Mon Sep 17 00:00:00 2001
From: Tanguy Le Carrour <tanguy@bioneland.org>
Date: Wed, 9 Oct 2019 09:39:17 +0200
Subject: [PATCH 3/9] gnu: Add python-shellingham.

---
 gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f98a2f21e5..b82631d8e2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10536,6 +10536,24 @@  docstring and colored output.")
     (description "Style preserving TOML library")
     (license license:expat)))
 
+(define-public python-shellingham
+  (package
+    (name "python-shellingham")
+    (version "1.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "shellingham" version))
+       (sha256
+        (base32
+         "1q7kws7w4x2hji3g7y0ni9ddk4sd676ylrb3db54gbpys6xj6nwq"))))
+    (build-system python-build-system)
+    (home-page
+     "https://github.com/sarugaku/shellingham")
+    (synopsis "Tool to Detect Surrounding Shell")
+    (description "Tool to Detect Surrounding Shell")
+    (license license:isc)))
+
 (define-public python-lazy-object-proxy
   (package
     (name "python-lazy-object-proxy")