diff mbox series

[bug#37704,2/9] gnu: Add python-tomlkit.

Message ID 20191011163808.cwb3gby74vuqndmp@rafflesia
State Accepted
Headers show
Series gnu: Add python-poetry. | expand

Commit Message

Tanguy LE CARROUR Oct. 11, 2019, 4:38 p.m. UTC
From 92d9d4b66f852e41f9068530e6128e99b3c7754a Mon Sep 17 00:00:00 2001
From: Tanguy Le Carrour <tanguy@bioneland.org>
Date: Wed, 9 Oct 2019 09:34:10 +0200
Subject: [PATCH 2/9] gnu: Add python-tomlkit.

---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ad48b75285..f98a2f21e5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10516,6 +10516,26 @@  docstring and colored output.")
 (define-public python2-cleo
   (package-with-python2 python-cleo))
 
+(define-public python-tomlkit
+  (package
+    (name "python-tomlkit")
+    (version "0.5.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "tomlkit" version))
+       (sha256
+        (base32
+         "18820ga5z3if1w8dvykxrfm000akracq01ic402xrbljgbn5grn4"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-pytest" ,python-pytest)))
+    (home-page
+     "https://github.com/sdispater/tomlkit")
+    (synopsis "Style preserving TOML library")
+    (description "Style preserving TOML library")
+    (license license:expat)))
+
 (define-public python-lazy-object-proxy
   (package
     (name "python-lazy-object-proxy")