[bug#34217,09/11] gnu: ruby-cucumber-core: Update to 3.2.1.

Message ID 20190127114956.26570-9-mail@cbaines.net
State Accepted
Headers show
Series Add ruby-cucumber along with dependencies and a couple of updates. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Christopher Baines Jan. 27, 2019, 11:49 a.m. UTC
Just update to major version 3, as version 4 of Cucumber hasn't been released
yet.

* gnu/packages/ruby.scm (ruby-cucumber-core): Update to 3.2.1.
[propagated-inputs]: Add ruby-backports, ruby-gherkin and
ruby-cucumber-tag-expressions.
---
 gnu/packages/ruby.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

Comments

Björn Höfling Feb. 3, 2019, 10:20 p.m. UTC | #1
On Sun, 27 Jan 2019 11:49:54 +0000
Christopher Baines <mail@cbaines.net> wrote:

> Just update to major version 3, as version 4 of Cucumber hasn't been
> released yet.

Can u move this into a comment in the source, such that it sticks
directly to the package?

Otherwise LGTM.

Björn
Christopher Baines Feb. 8, 2019, 6:48 p.m. UTC | #2
Björn Höfling <bjoern.hoefling@bjoernhoefling.de> writes:

> On Sun, 27 Jan 2019 11:49:54 +0000
> Christopher Baines <mail@cbaines.net> wrote:
>
>> Just update to major version 3, as version 4 of Cucumber hasn't been
>> released yet.
>
> Can u move this into a comment in the source, such that it sticks
> directly to the package?

Sure, I've added the following comment to the patch.

  ;; Stick to major version 3, until version 4 of Cucumber is released.

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 538cae9021..ddaf9e1bc3 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3798,17 +3798,19 @@  files.")
 (define-public ruby-cucumber-core
   (package
     (name "ruby-cucumber-core")
-    (version "2.0.0")
+    (version "3.2.1")
     (source
      (origin
        (method url-fetch)
        (uri (rubygems-uri "cucumber-core" version))
        (sha256
         (base32
-         "136hnvqv444qyxzcgy1k60y4i6cn3sn9lbqr4wan9dzz1yzllqbm"))))
+         "1iavlh8hqj9lwljbpkw06259gdicbr1bdb6pbj5yy3n8szgr8k3c"))))
     (build-system ruby-build-system)
     (propagated-inputs
-     `(("ruby-gherkin" ,ruby-gherkin)))
+     `(("ruby-backports" ,ruby-backports)
+       ("ruby-gherkin" ,ruby-gherkin)
+       ("ruby-cucumber-tag-expressions" ,ruby-cucumber-tag-expressions)))
     (native-inputs
      `(("bundler" ,bundler)))
     (arguments