[bug#34217,07/11] gnu: Add ruby-backports.

Message ID 20190127114956.26570-7-mail@cbaines.net
State Accepted
Commit f7e9b2f37541e6863dc72c924148fa6ed28b39c1
Headers show
Series Add ruby-cucumber along with dependencies and a couple of updates. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Christopher Baines Jan. 27, 2019, 11:49 a.m. UTC
* gnu/packages/ruby.scm (ruby-backports): New variable.
---
 gnu/packages/ruby.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

swedebugia Jan. 31, 2019, 8:53 a.m. UTC | #1
On 2019-01-27 12:49, Christopher Baines wrote:
> * gnu/packages/ruby.scm (ruby-backports): New variable.
> ---
>   gnu/packages/ruby.scm | 25 +++++++++++++++++++++++++
>   1 file changed, 25 insertions(+)
> 
> diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
> index 5a9a9a7c6d..115e132b95 100644
> --- a/gnu/packages/ruby.scm
> +++ b/gnu/packages/ruby.scm
> @@ -1350,6 +1350,31 @@ User Agents.")
>       (home-page "https://github.com/gshutler/useragent")
>       (license license:expat)))
>   
> +(define-public ruby-backports
> +  (package
> +  (name "ruby-backports")
> +  (version "3.11.4")
> +  (source
> +    (origin
> +      (method url-fetch)
> +      (uri (rubygems-uri "backports" version))
> +      (sha256
> +        (base32
> +          "1hshjxww2h7s0dk57njrygq4zpp0nlqrjfya7zwm27iq3rhc3y8g"))))
> +  (build-system ruby-build-system)
> +  (arguments
> +   '(;; TODO: This should be default, but there is one test failure
> +     #:test-target "all_spec"))

The failure is reported upstream, see 
https://github.com/marcandre/backports/issues/127
swedebugia Feb. 1, 2019, 3:41 p.m. UTC | #2
swedebugia <swedebugia@riseup.net> skrev: (31 januari 2019 09:53:17 CET)
>On 2019-01-27 12:49, Christopher Baines wrote:
>> * gnu/packages/ruby.scm (ruby-backports): New variable.
>> ---
>>   gnu/packages/ruby.scm | 25 +++++++++++++++++++++++++
>>   1 file changed, 25 insertions(+)
>> 
>> diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
>> index 5a9a9a7c6d..115e132b95 100644
>> --- a/gnu/packages/ruby.scm
>> +++ b/gnu/packages/ruby.scm
>> @@ -1350,6 +1350,31 @@ User Agents.")
>>       (home-page "https://github.com/gshutler/useragent")
>>       (license license:expat)))
>>   
>> +(define-public ruby-backports
>> +  (package
>> +  (name "ruby-backports")
>> +  (version "3.11.4")
>> +  (source
>> +    (origin
>> +      (method url-fetch)
>> +      (uri (rubygems-uri "backports" version))
>> +      (sha256
>> +        (base32
>> +          "1hshjxww2h7s0dk57njrygq4zpp0nlqrjfya7zwm27iq3rhc3y8g"))))
>> +  (build-system ruby-build-system)
>> +  (arguments
>> +   '(;; TODO: This should be default, but there is one test failure
>> +     #:test-target "all_spec"))
>
>The failure is reported upstream, see 
>https://github.com/marcandre/backports/issues/127
>
>-- 
>Cheers
>Swedebugia

From upstream:
Sorry the failure is quite obscure.

Backports wants to make sure it is defining the right methods only when necessary. The test is failing because the method alias_method_chainappears to have been added to all modules (Array, Binding, ...). Maybe the old backports/rails/module/alias_method_chain is somehow loaded, but I don't see how or why...
Christopher Baines Feb. 8, 2019, 7:10 p.m. UTC | #3
swedebugia <swedebugia@riseup.net> writes:

> swedebugia <swedebugia@riseup.net> skrev: (31 januari 2019 09:53:17 CET)
>>On 2019-01-27 12:49, Christopher Baines wrote:
>>> * gnu/packages/ruby.scm (ruby-backports): New variable.
>>> ---
>>>   gnu/packages/ruby.scm | 25 +++++++++++++++++++++++++
>>>   1 file changed, 25 insertions(+)
>>> 
>>> diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
>>> index 5a9a9a7c6d..115e132b95 100644
>>> --- a/gnu/packages/ruby.scm
>>> +++ b/gnu/packages/ruby.scm
>>> @@ -1350,6 +1350,31 @@ User Agents.")
>>>       (home-page "https://github.com/gshutler/useragent")
>>>       (license license:expat)))
>>>   
>>> +(define-public ruby-backports
>>> +  (package
>>> +  (name "ruby-backports")
>>> +  (version "3.11.4")
>>> +  (source
>>> +    (origin
>>> +      (method url-fetch)
>>> +      (uri (rubygems-uri "backports" version))
>>> +      (sha256
>>> +        (base32
>>> +          "1hshjxww2h7s0dk57njrygq4zpp0nlqrjfya7zwm27iq3rhc3y8g"))))
>>> +  (build-system ruby-build-system)
>>> +  (arguments
>>> +   '(;; TODO: This should be default, but there is one test failure
>>> +     #:test-target "all_spec"))
>>
>>The failure is reported upstream, see 
>>https://github.com/marcandre/backports/issues/127
>>
>>-- 
>>Cheers
>>Swedebugia
>
> From upstream:
> Sorry the failure is quite obscure.
>
> Backports wants to make sure it is defining the right methods only when necessary. The test is failing because the methodalias_method_chainappears to have been added to all modules (Array,Binding, ...). Maybe the oldbackports/rails/module/alias_method_chainis somehow loaded, but I don't see how or why...

Thanks for taking a look, I'll keep an eye on that upstream issue.

Chris

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5a9a9a7c6d..115e132b95 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1350,6 +1350,31 @@  User Agents.")
     (home-page "https://github.com/gshutler/useragent")
     (license license:expat)))
 
+(define-public ruby-backports
+  (package
+  (name "ruby-backports")
+  (version "3.11.4")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (rubygems-uri "backports" version))
+      (sha256
+        (base32
+          "1hshjxww2h7s0dk57njrygq4zpp0nlqrjfya7zwm27iq3rhc3y8g"))))
+  (build-system ruby-build-system)
+  (arguments
+   '(;; TODO: This should be default, but there is one test failure
+     #:test-target "all_spec"))
+  (native-inputs
+   `(("ruby-mspec" ,ruby-mspec)
+     ("ruby-activesupport" ,ruby-activesupport)))
+  (synopsis "Backports of the features in newer Ruby versions")
+  (description
+    "Backports enables more compatibility across Ruby versions by providing
+backports of some features.")
+  (home-page "https://github.com/marcandre/backports")
+  (license license:expat)))
+
 (define-public ruby-bacon
   (package
     (name "ruby-bacon")