[bug#34217,01/11] gnu: Add ruby-cucumber-wire.

Message ID 20190127114956.26570-1-mail@cbaines.net
State Accepted
Headers show
Series Add ruby-cucumber along with dependencies and a couple of updates. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Christopher Baines Jan. 27, 2019, 11:49 a.m. UTC
Package version 0.0.1 initially, as this is what's needed by Cucumber 3, and
Cucumber 4 hasn't been released yet.

* gnu/packages/ruby.scm (ruby-cucumber-wire): New variable.
---
 gnu/packages/ruby.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Björn Höfling Feb. 3, 2019, 9:03 p.m. UTC | #1
On Sun, 27 Jan 2019 11:49:46 +0000
Christopher Baines <mail@cbaines.net> wrote:

> Package version 0.0.1 initially, as this is what's needed by Cucumber
> 3, and Cucumber 4 hasn't been released yet.

I would prefer to see this hint as a comment in the code, not in the
commit message: When I as a developer stumble upon the package
definition and see it is outdated, I would just update it and not
search all commit messages to find out it shouldn't. A comment near the
package definition or version would prevent that mistake.

Otherwise, LGTM.

Thanks,

Björn
Christopher Baines Feb. 8, 2019, 7:05 p.m. UTC | #2
Björn Höfling <bjoern.hoefling@bjoernhoefling.de> writes:

> On Sun, 27 Jan 2019 11:49:46 +0000
> Christopher Baines <mail@cbaines.net> wrote:
>
>> Package version 0.0.1 initially, as this is what's needed by Cucumber
>> 3, and Cucumber 4 hasn't been released yet.
>
> I would prefer to see this hint as a comment in the code, not in the
> commit message: When I as a developer stumble upon the package
> definition and see it is outdated, I would just update it and not
> search all commit messages to find out it shouldn't. A comment near the
> package definition or version would prevent that mistake.

Sure, I've added a comment to the package definition.

Thanks for taking a look,

Chris

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index c6a65ffc58..649c7aa464 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3650,6 +3650,39 @@  and trust on your team.")
     (home-page "https://cucumber.io/")
     (license license:expat)))
 
+(define-public ruby-cucumber-wire
+  (package
+    (name "ruby-cucumber-wire")
+    (version "0.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "cucumber-wire" version))
+       (sha256
+        (base32
+         "09ymvqb0sbw2if1nxg8rcj33sf0va88ancq5nmp8g01dfwzwma2f"))))
+    (build-system ruby-build-system)
+    (arguments
+     '(;; TODO: Currently, the tests can't be run as cucumber is required,
+       ;; which would lead to a circular dependency.
+       #:tests? #f
+       #:test-target "default"
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'set-CUCUMBER_USE_RELEASED_GEMS
+           (lambda _
+             (setenv "CUCUMBER_USE_RELEASED_GEMS" "true")
+             #t)))))
+    (native-inputs
+     `(("bundler" ,bundler)
+       ("ruby-rspec" ,ruby-rspec)))
+    (synopsis "Cucumber wire protocol plugin")
+    (description
+     "Cucumber's wire protocol allows step definitions to be implemented and
+invoked on any platform.")
+    (home-page "https://github.com/cucumber/cucumber-ruby-wire")
+    (license license:expat)))
+
 (define-public ruby-bio-logger
   (package
     (name "ruby-bio-logger")