[bug#34217,03/11] gnu: Add ruby-ruby-progressbar.

Message ID 20190127114956.26570-3-mail@cbaines.net
State Accepted
Headers show
Series Add ruby-cucumber along with dependencies and a couple of updates. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Christopher Baines Jan. 27, 2019, 11:49 a.m. UTC
* gnu/packages/ruby.scm (ruby-ruby-progressbar): New variable.
---
 gnu/packages/ruby.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Björn Höfling Feb. 3, 2019, 9:40 p.m. UTC | #1
On Sun, 27 Jan 2019 11:49:48 +0000
Christopher Baines <mail@cbaines.net> wrote:

> * gnu/packages/ruby.scm (ruby-ruby-progressbar): New variable.
> ---
>  gnu/packages/ruby.scm | 22 ++++++++++++++++++++++
>  1 file changed, 22 insertions(+)
> 
> diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
> index 808b2d8686..15382de017 100644
> --- a/gnu/packages/ruby.scm
> +++ b/gnu/packages/ruby.scm
> @@ -2507,6 +2507,28 @@ rate.")
>      (home-page "https://github.com/paul/progress_bar")
>      (license license:wtfpl2)))
>  
> +(define-public ruby-ruby-progressbar
> +  (package
> +    (name "ruby-ruby-progressbar")

Although we do not have a specific section about Ruby packages, I would
stick to the rules for Python packages:

https://www.gnu.org/software/guix/manual/en/guix.html#Python-Modules

"If a project already contains the word python, we drop this; for
instance, the module python-dateutil is packaged under the names python-dateutil"

Thus, rename the package to just "ruby-progressbar".

Otherwise, LGTM.

Thanks,

Björn
Christopher Baines Feb. 8, 2019, 6:58 p.m. UTC | #2
Björn Höfling <bjoern.hoefling@bjoernhoefling.de> writes:

> On Sun, 27 Jan 2019 11:49:48 +0000
> Christopher Baines <mail@cbaines.net> wrote:
>
>> * gnu/packages/ruby.scm (ruby-ruby-progressbar): New variable.
>> ---
>>  gnu/packages/ruby.scm | 22 ++++++++++++++++++++++
>>  1 file changed, 22 insertions(+)
>>
>> diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
>> index 808b2d8686..15382de017 100644
>> --- a/gnu/packages/ruby.scm
>> +++ b/gnu/packages/ruby.scm
>> @@ -2507,6 +2507,28 @@ rate.")
>>      (home-page "https://github.com/paul/progress_bar")
>>      (license license:wtfpl2)))
>>
>> +(define-public ruby-ruby-progressbar
>> +  (package
>> +    (name "ruby-ruby-progressbar")
>
> Although we do not have a specific section about Ruby packages, I would
> stick to the rules for Python packages:
>
> https://www.gnu.org/software/guix/manual/en/guix.html#Python-Modules
>
> "If a project already contains the word python, we drop this; for
> instance, the module python-dateutil is packaged under the names python-dateutil"
>
> Thus, rename the package to just "ruby-progressbar".

That makes sense, I've updated the name of the package and the
references.

Thanks,

Chris

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 808b2d8686..15382de017 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2507,6 +2507,28 @@  rate.")
     (home-page "https://github.com/paul/progress_bar")
     (license license:wtfpl2)))
 
+(define-public ruby-ruby-progressbar
+  (package
+    (name "ruby-ruby-progressbar")
+    (version "1.10.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "ruby-progressbar" version))
+       (sha256
+        (base32
+         "1cv2ym3rl09svw8940ny67bav7b2db4ms39i4raaqzkf59jmhglk"))))
+    (build-system ruby-build-system)
+    (arguments
+     '(;; TODO: There looks to be a circular dependency with ruby-fuubar.
+       #:tests? #f))
+    (synopsis "Text progress bar library for Ruby")
+    (description
+     "Ruby/ProgressBar is an flexible text progress bar library for Ruby.
+The output can be customized with a formatting system.")
+    (home-page "https://github.com/jfelchner/ruby-progressbar")
+    (license license:expat)))
+
 (define-public ruby-pry
   (package
     (name "ruby-pry")