[bug#34217,10/11] gnu: ruby-gherkin: Update to 5.1.0.

Message ID 20190127114956.26570-10-mail@cbaines.net
State Accepted
Commit aada5f6f3b128a0b97c0ca8be110d897f900c7bd
Headers show
Series Add ruby-cucumber along with dependencies and a couple of updates. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Christopher Baines Jan. 27, 2019, 11:49 a.m. UTC
Don't upgrade all the way to version 6, as version 5 is needed for Cucumber 3.

* gnu/packages/ruby.scm (ruby-gherkin): Update to 5.1.0.
[description]: Use @file{ }.
---
 gnu/packages/ruby.scm | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index ddaf9e1bc3..e507c816c8 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3775,14 +3775,14 @@  Ruby classes.")
 (define-public ruby-gherkin
   (package
     (name "ruby-gherkin")
-    (version "4.1.3")
+    (version "5.1.0")
     (source
       (origin
         (method url-fetch)
         (uri (rubygems-uri "gherkin" version))
         (sha256
           (base32
-            "1d18r8mf2qyd9jbq9xxvca8adyysdzvwdy8v9c2s5hrd6p02kg79"))))
+            "1cgcdchwwdm10rsk44frjwqd4ihprhxjbm799nscqy2q1raqfj5s"))))
     (build-system ruby-build-system)
     (native-inputs
      `(("bundler" ,bundler)))
@@ -3790,9 +3790,9 @@  Ruby classes.")
      '(#:tests? #f)) ; needs simplecov, among others
     (synopsis "Gherkin parser for Ruby")
     (description "Gherkin is a parser and compiler for the Gherkin language.
-It is intended be used by all Cucumber implementations to parse '.feature'
-files.")
-    (home-page "https://github.com/cucumber/gherkin3")
+It is intended be used by all Cucumber implementations to parse
+@file{.feature} files.")
+    (home-page "https://github.com/cucumber-attic/gherkin")
     (license license:expat)))
 
 (define-public ruby-cucumber-core