[bug#64225,8/9] gnu: Add texlive-pgfplots.
Commit Message
* gnu/packages/tex.scm (texlive-pgfplots): New variable.
---
gnu/packages/tex.scm | 43 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)
--
2.40.1
@@ -9853,6 +9853,49 @@ (define-public texlive-pgf
(define-deprecated-package texlive-latex-pgf texlive-pgf)
+(define-public texlive-pgfplots
+ (package
+ (inherit (simple-texlive-package
+ "texlive-pgfplots"
+ (list "doc/context/third/pgfplots/"
+ "doc/generic/pgfplots/"
+ "doc/latex/pgfplots/"
+ "doc/plain/pgfplots/"
+ "scripts/pgfplots/"
+ "source/context/third/pgfplots/"
+ "source/latex/pgfplots/"
+ "tex/context/third/pgfplots/"
+ "tex/generic/pgfplots/"
+ "tex/generic/pgfplots/libs/"
+ "tex/generic/pgfplots/liststructure/"
+ "tex/generic/pgfplots/lua/"
+ "tex/generic/pgfplots/lua/pgfplots/"
+ "tex/generic/pgfplots/lua/pgfplotsoldpgfsupp/luamath/"
+ "tex/generic/pgfplots/numtable/"
+ "tex/generic/pgfplots/oldpgfcompatib/"
+ "tex/generic/pgfplots/oldpgfplotscompatib/"
+ "tex/generic/pgfplots/pgfcontrib/"
+ "tex/generic/pgfplots/sys/"
+ "tex/generic/pgfplots/test/"
+ "tex/generic/pgfplots/util/"
+ "tex/latex/pgfplots/"
+ "tex/latex/pgfplots/libs/"
+ "tex/plain/pgfplots/")
+ (base32
+ "08ahzc3yvqj31m018d313bbhvcka59dfdmphlrsavqk68x9023k1")
+ #:trivial? #t))
+ (propagated-inputs (list texlive-pgf))
+ (home-page "https://ctan.org/graphics/pgf/contrib/pgfplots")
+ (synopsis "Create normal/logarithmic plots in two and three dimensions")
+ (description
+ "PGFPlots draws high-quality function plots in normal or logarithmic scaling with
+a user-friendly interface directly in TeX. The user supplies axis labels, legend
+entries and the plot coordinates for one or more plots and PGFPlots applies axis
+scaling, computes any logarithms and axis ticks and draws the plots, supporting
+line plots, scatter plots, piecewise constant plots, bar plots, area plots,
+mesh-- and surface plots and some more. Pgfplots is based on PGF/TikZ (PGF); it
+runs equally for LaTeX/TeX/ConTeXt.")))
+
(define-public texlive-latex-koma-script
(package
(name "texlive-latex-koma-script")