diff mbox series

[bug#64225,2/9] gnu: Add texlive-svg.

Message ID 01020188e2f5d108-1cb96f3d-b202-4ab4-9a3c-34eb8c3e985f-000000@eu-west-1.amazonses.com
State New
Headers show
Series Adding unrelated texlive packages | expand

Commit Message

reza June 22, 2023, 11:55 a.m. UTC
* gnu/packages/tex.scm (texlive-svg): New variable.
---
 gnu/packages/tex.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

-- 
2.40.1
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 82eb93c941..566a9fa0e8 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3564,6 +3564,31 @@  (define-public texlive-graphics
 
 (define-deprecated-package texlive-latex-graphics texlive-graphics)
 
+(define-public texlive-svg
+  (package
+    (inherit (simple-texlive-package
+	      "texlive-svg"
+              (list "doc/latex/svg/"
+		    "source/latex/svg/"
+                    "tex/latex/svg/")
+              (base32
+               "1yizgrjn6l9j1cf8mvkjz0zni7bzmajszc1y8q80xc723nwnbq7q")
+	      #:trivial? #t))
+    (home-page "https://ctan.org/graphics/svg")
+    (synopsis "Include and extract SVG pictures in LaTeX documents")
+    (description
+     "This bundle contains the two packages svg and svg-extract.  The svg package is
+intended for the automated integration of SVG graphics into LaTeX documents.
+Therefore the capabilities provided by Inkscape -- or more precisely its command
+line tool -- are used to export the text within an SVG graphic to a separate
+file, which is then rendered by LaTeX. For this purpose the two commands
+\\includesvg and \\includeinkscape are provided which are very similar to the
+\\includegraphics command of the graphicx package.  In addition, the package
+svg-extract allows the extraction of these graphics into independent files in
+different graphic formats, exactly as it is rendered within the LaTeX document,
+using either ImageMagick or Ghostscript.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-greek-fontenc
   (package
     (inherit (simple-texlive-package