diff mbox series

[bug#64225,1/9] gnu: Add texlive-filehook.

Message ID 01020188e2f5bdbe-3f1c5d58-8ce3-411b-ba87-715786d3a3d2-000000@eu-west-1.amazonses.com
State New
Headers show
Series Adding unrelated texlive packages | expand

Commit Message

reza June 22, 2023, 11:55 a.m. UTC
* gnu/packages/tex.scm (texlive-filehook): New variable.
---
 gnu/packages/tex.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

-- 
2.40.1
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b55dd2a5fd..82eb93c941 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3397,6 +3397,26 @@  (define-public texlive-filecontents
 
 (define-deprecated-package texlive-latex-filecontents texlive-filecontents)
 
+(define-public texlive-filehook
+  (package
+    (inherit (simple-texlive-package
+	      "texlive-filehook"
+              (list "doc/latex/filehook/"
+                    "source/latex/filehook/"
+                    "tex/latex/filehook/")
+              (base32
+               "03dsnv8fn111kn8h2fa281w2jvcdrqag1im6mkkfahvjgl1apk6k")
+	      #:trivial? #t))
+    (home-page "https://ctan.org/macros/latex/contrib/filehook")
+    (synopsis "Hooks for input files")
+    (description
+     "The package provides several file hooks (AtBegin, AtEnd, ...) for files read by
+\\input, \\include and \\InputIfFileExists.  General hooks for all such files (e.g.
+ all \\included ones) and file specific hooks only used for named files are
+provided; two hooks are provided for the end of \\included files -- one before,
+and one after the final \\clearpage.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-epsf
   (package
     (inherit (simple-texlive-package