diff mbox series

[bug#64225,4/9] gnu: Add texlive-lualatex-math.

Message ID 01020188e2f5ee30-8a2b77a0-1ad8-4fc1-9020-94e245f6e09f-000000@eu-west-1.amazonses.com
State New
Headers show
Series Adding unrelated texlive packages | expand

Commit Message

reza June 22, 2023, 11:55 a.m. UTC
* gnu/packages/tex.scm (texlive-lualatex-math): New variable.
---
 gnu/packages/tex.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

-- 
2.40.1
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b6f44732e2..37244ca76b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4476,6 +4476,28 @@  (define-public texlive-luaotfload
 
 (define-deprecated-package texlive-luatex-luaotfload texlive-luaotfload)
 
+(define-public texlive-lualatex-math
+  (package
+    (inherit (simple-texlive-package
+	      "texlive-lualatex-math"
+              (list "doc/lualatex/lualatex-math/"
+                    "source/lualatex/lualatex-math/"
+                    "tex/lualatex/lualatex-math/")
+              (base32
+               "1xfr31rwr7zc6d5bsc3v5lwvcfrg109rzfgvvs69w4xs61j06jcg")
+	      #:trivial? #t))
+    (propagated-inputs (list texlive-filehook texlive-etoolbox))
+    (home-page "https://ctan.org/macros/luatex/latex/lualatex-math")
+    (synopsis "Fixes for mathematics-related LuaLaTeX issues")
+    (description
+     "The package patches a few commands of the LaTeX2e kernel and the amsmath and
+mathtools packages to be more compatible with the LuaTeX engine.  It is only
+meaningful for LuaLaTeX documents containing mathematical formulas, and does not
+exhibit any new functionality.  The fixes are mostly moved from the unicode-math
+package to this package since they are not directly related to Unicode
+mathematics typesetting.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-amsmath
   (let ((template (simple-texlive-package
                    "texlive-amsmath"