diff mbox series

[bug#68556,gnome-team,v2,22/23] gnu: Add gnome-shell-extension-v-shell.

Message ID 00ab34f77dca537fa6005de714d8db3629eab27d.1705701031.git.vivien@planete-kraus.eu
State New
Headers show
Series Update extensions with 3 replacements | expand

Commit Message

Vivien Kraus Jan. 18, 2024, 6:19 p.m. UTC
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-v-shell): New variable.

Change-Id: Ib7e3cf5cffed621e2ccd54c84004c5ab8504fa9a
---
 gnu/packages/gnome-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 89a5426e98..bc1f3dd51f 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1063,6 +1063,42 @@  (define-public gpaste
 copies you now want to paste.")
     (license license:bsd-2)))
 
+(define-public gnome-shell-extension-v-shell
+  (package
+    (name "gnome-shell-extension-v-shell")
+    (version "37")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/G-dH/vertical-workspaces")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32
+         "1h9f3g1dswxkka0yyj51610w86mwl46ylch19b51gj5mmxlyvzlv"))
+       (file-name (git-file-name name version))))
+    (build-system copy-build-system)
+    (arguments
+     (list
+      #:install-plan
+      #~'(("." #$(string-append
+                  "share/gnome-shell/extensions/"
+                  "vertical-workspaces@G-dH.github.com")
+           #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
+                             "\\.xml$" "\\.compiled$" "\\.gresource$")))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'install 'build
+            (lambda _
+              (invoke "make" "all"))))))
+    (native-inputs
+     (list gettext-minimal `(,glib "bin")))
+    (home-page "https://github.com/G-dH/vertical-workspaces")
+    (synopsis "Shell configuration with horizontal or vertical workspaces")
+    (description "V-Shell (Vertical Workspaces) lets the user configure different parts of the
+shell, including panels, corners, workspaces.")
+    (license license:gpl3)))
+
 (define-public gnome-shell-extension-vertical-overview
   (package
     (name "gnome-shell-extension-vertical-overview")