diff mbox series

[bug#68556,gnome-team,v2,23/23] gnu: gnome-shell-extension-vertical-overview: Deprecate.

Message ID a4d7ebda16fb8f01ac520fb1505f91b0a5e48864.1705701031.git.vivien@planete-kraus.eu
State New
Headers show
Series Update extensions with 3 replacements | expand

Commit Message

Vivien Kraus Jan. 18, 2024, 6:19 p.m. UTC
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-vertical-overview):
Replace with gnome-shell-extension-v-shell.

Change-Id: I1c6539fd6532046f8445ee33b286645b9e68a053
---
 gnu/packages/gnome-xyz.scm | 39 ++------------------------------------
 1 file changed, 2 insertions(+), 37 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index bc1f3dd51f..71069540dd 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1100,43 +1100,8 @@  (define-public gnome-shell-extension-v-shell
     (license license:gpl3)))
 
 (define-public gnome-shell-extension-vertical-overview
-  (package
-    (name "gnome-shell-extension-vertical-overview")
-    (version "10")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/RensAlthuis/vertical-overview")
-             (commit (string-append "v" version))))
-       (sha256
-        (base32
-         "1sqkbg93qqrq47wyfnh2flg7dpsmv5c2pmkx8kgqhnbl7j2kgi0l"))
-       (file-name (git-file-name name version))
-       (snippet
-        '(begin (delete-file "schemas/gschemas.compiled")))))
-    (build-system copy-build-system)
-    (arguments
-     `(#:install-plan
-       '(("." ,(string-append
-                "share/gnome-shell/extensions/"
-                "vertical-overview@RensAlthuis.github.com")
-          #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
-                            "\\.xml$" "\\.compiled$")))
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'install 'compile-schemas
-           (lambda _
-             (with-directory-excursion "schemas"
-               (invoke "glib-compile-schemas" ".")))))))
-    (native-inputs
-     (list `(,glib "bin")))  ; for glib-compile-resources
-    (home-page "https://github.com/RensAlthuis/vertical-overview")
-    (synopsis "Provides a vertical overview in Gnome 40 and upper")
-    (description "This Gnome extension replaces the new horizontally oriented
-Gnome overview with something that resembles the old vertically oriented
-style.")
-    (license license:gpl3)))
+  (deprecated-package "gnome-shell-extension-vertical-overview"
+                      gnome-shell-extension-v-shell))
 
 (define-public gnome-shell-extension-burn-my-windows
   (package