diff mbox series

[bug#68556,gnome-team,v2,12/23] gnu: gnome-shell-extension-burn-my-windows: Update to 40.

Message ID 1951662ab40d06b15f95c9bf6d30c2d14f1ca09e.1705701031.git.vivien@planete-kraus.eu
State New
Headers show
Series Update extensions with 3 replacements | expand

Commit Message

Vivien Kraus Jan. 17, 2024, 9:57 p.m. UTC
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-burn-my-windows): Update
to 40.
[arguments]: Convert to list of G-Expressions.

Change-Id: Ib9551096437aeea0ff56e5e1ea6371ab72d61b02
---
 gnu/packages/gnome-xyz.scm | 35 ++++++++++++++++++-----------------
 1 file changed, 18 insertions(+), 17 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 89ba3cdbb7..b9d0d29706 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1178,7 +1178,7 @@  (define-public gnome-shell-extension-jiggle
 (define-public gnome-shell-extension-burn-my-windows
   (package
     (name "gnome-shell-extension-burn-my-windows")
-    (version "22")
+    (version "40")
     (source
      (origin
        (method git-fetch)
@@ -1187,25 +1187,26 @@  (define-public gnome-shell-extension-burn-my-windows
              (commit (string-append "v" version))))
        (sha256
         (base32
-         "185xrf330d9bflmk0l61cnzlylnppb2v4yz6v6ygkk4zpwyil8np"))
+         "16n6ilszdn67835clqlr4flna69x9k00k5qrm55765dv2ny9jdcq"))
        (file-name (git-file-name name version))))
     (build-system copy-build-system)
     (arguments
-     `(#:install-plan
-       '(("." ,(string-append
-                "share/gnome-shell/extensions/"
-                "burn-my-windows@schneegans.github.com")
-          #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
-                            "\\.xml$" "\\.compiled$" "\\.gresource$")))
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'install 'compile-resources
-           (lambda _
-             (invoke "make" "resources/burn-my-windows.gresource")))
-         (add-before 'install 'compile-schemas
-           (lambda _
-             (with-directory-excursion "schemas"
-               (invoke "glib-compile-schemas" ".")))))))
+     (list
+      #:install-plan
+      #~'(("." #$(string-append
+                  "share/gnome-shell/extensions/"
+                  "burn-my-windows@schneegans.github.com")
+           #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
+                             "\\.xml$" "\\.compiled$" "\\.gresource$")))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'install 'compile-resources
+            (lambda _
+              (invoke "make" "resources/burn-my-windows.gresource")))
+          (add-before 'install 'compile-schemas
+            (lambda _
+              (with-directory-excursion "schemas"
+                (invoke "glib-compile-schemas" ".")))))))
     (native-inputs
      (list `(,glib "bin")))  ; for glib-compile-resources
     (home-page "https://github.com/Schneegans/Burn-My-Windows")