diff mbox series

[bug#68556,gnome-team,v2,16/23] gnu: Add gnome-shell-extension-noannoyance-fork.

Message ID 4b9d2a301a45919e9b4503aa86193623eb2c4f27.1705701031.git.vivien@planete-kraus.eu
State New
Headers show
Series Update extensions with 3 replacements | expand

Commit Message

Vivien Kraus Jan. 17, 2024, 10:32 p.m. UTC
The NoAnnoyance “v2” project has not been ported to GNOME 44, so we switch to
a maintained fork.

* gnu/packages/gnome-xyz.scm (gnome-shell-extension-noannoyance-fork): New variable.

Change-Id: Ic74d832020dfe3857e1abf450f5d7876cc921a28
---
 gnu/packages/gnome-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Liliana Marie Prikler Jan. 19, 2024, 10:33 p.m. UTC | #1
Am Mittwoch, dem 17.01.2024 um 23:32 +0100 schrieb Vivien Kraus:
> The NoAnnoyance “v2” project has not been ported to GNOME 44, so we
> switch to a maintained fork.
> 
> * gnu/packages/gnome-xyz.scm (gnome-shell-extension-noannoyance-
> fork): New variable.
> 
> Change-Id: Ic74d832020dfe3857e1abf450f5d7876cc921a28
> ---
Instead of introducing another variable and deprecating the former, it
makes sense to just update the origin, version, hash, etc.

Cheers
Vivien Kraus Jan. 19, 2024, 10:35 p.m. UTC | #2
Le vendredi 19 janvier 2024 à 23:33 +0100, Liliana Marie Prikler a
écrit :
> Am Mittwoch, dem 17.01.2024 um 23:32 +0100 schrieb Vivien Kraus:
> > The NoAnnoyance “v2” project has not been ported to GNOME 44, so we
> > switch to a maintained fork.
> > 
> > * gnu/packages/gnome-xyz.scm (gnome-shell-extension-noannoyance-
> > fork): New variable.
> > 
> > Change-Id: Ic74d832020dfe3857e1abf450f5d7876cc921a28
> > ---
> Instead of introducing another variable and deprecating the former,
> it
> makes sense to just update the origin, version, hash, etc.

The version number restarts at 1 (according to extensions.gnome.org),
won’t that be a problem?

Vivien
Liliana Marie Prikler Jan. 19, 2024, 11:35 p.m. UTC | #3
Am Freitag, dem 19.01.2024 um 23:35 +0100 schrieb Vivien Kraus:
> Le vendredi 19 janvier 2024 à 23:33 +0100, Liliana Marie Prikler a
> écrit :
> > Am Mittwoch, dem 17.01.2024 um 23:32 +0100 schrieb Vivien Kraus:
> > > The NoAnnoyance “v2” project has not been ported to GNOME 44, so
> > > we switch to a maintained fork.
> > > 
> > > * gnu/packages/gnome-xyz.scm (gnome-shell-extension-noannoyance-
> > > fork): New variable.
> > > 
> > > Change-Id: Ic74d832020dfe3857e1abf450f5d7876cc921a28
> > > ---
> > Instead of introducing another variable and deprecating the former,
> > it makes sense to just update the origin, version, hash, etc.
> 
> The version number restarts at 1 (according to extensions.gnome.org),
> won’t that be a problem?
I think we can count this as 16 - revision - commit, since it was
forked somewhere around there.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 0f71e0e242..3f1d9342c0 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -946,6 +946,34 @@  (define-public gnome-shell-extension-dash-to-panel
     (home-page "https://github.com/home-sweet-gnome/dash-to-panel/")
     (license license:gpl2+)))
 
+(define-public gnome-shell-extension-noannoyance-fork
+  (let ((revision "1")
+        (commit "5e9e6a1878d2a1d961f5d59505f15339c5b7e17e"))
+    (package
+      ;; This is the “fork” version:
+      ;; https://extensions.gnome.org/extension/6109/noannoyance-fork/
+      (name "gnome-shell-extension-noannoyance-fork")
+      (version (git-version "1" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/jirkavrba/noannoyance")
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "0br9zrwvn499kh3db84hhw1kl02jpchwb5ldfp892p15vwih8yrf"))
+                (file-name (git-file-name name version))))
+      (build-system copy-build-system)
+      (arguments
+       (list
+        #:install-plan
+        #~'(("." "share/gnome-shell/extensions/noannoyance@vrba.dev"))))
+      (synopsis "Remove 'Window is ready' annotation")
+      (description "One of the many extensions that remove this message.
+It uses ES6 syntax and claims to be more actively maintained than others.")
+      (home-page "https://extensions.gnome.org/extension/2182/noannoyance/")
+      (license license:gpl2))))
+
 (define-public gnome-shell-extension-noannoyance
   (let ((revision "1")
         (commit "b759d10fd2799bc084007fdd927b62637c3dbd2c"))