diff mbox series

[bug#68556,gnome-team,v2,03/23] gnu: gnome-shell-extension-hide-app-icon: Deprecate.

Message ID b3af3b2392566d2b92d6f1dad5e25d14fb884980.1705701031.git.vivien@planete-kraus.eu
State New
Headers show
Series Update extensions with 3 replacements | expand

Commit Message

Vivien Kraus Jan. 17, 2024, 4:20 p.m. UTC
This extension does not work with GNOME 44, and has not received any
work. However, Just Perfection seems to have an option to hide application
icons.

* gnu/packages/gnome-xyz.scm (gnome-shell-extension-hide-app-icon): Deprecate
in favor of gnome-shell-extension-hide-app-icon.

Change-Id: I6af14b6c9e1db7176d9be6bec2b90f77e7db36c1
---
 gnu/packages/gnome-xyz.scm | 48 ++------------------------------------
 1 file changed, 2 insertions(+), 46 deletions(-)

Comments

Vivien Kraus Jan. 19, 2024, 10:20 p.m. UTC | #1
Le mercredi 17 janvier 2024 à 17:20 +0100, Vivien Kraus a écrit :
> +  (deprecated-package "gnome-shell-extension-hide-app-icon"
> +                      gnome-shell-extension-just-perfection))
>  
>  (define-public gnome-shell-extension-just-perfection
>    (package

There’s a mishap here: you have to swap the order of gnome-shell-
extension-hide-app-icon and gnome-shell-extension-just-perfection in
the file.

Sorry.

Vivien
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 1ba5162597..c278f47263 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -852,52 +852,8 @@  (define-public gnome-shell-extension-gsconnect
     (license license:gpl2)))
 
 (define-public gnome-shell-extension-hide-app-icon
-  (let ((commit "4188aa5f4ba24901a053a0c3eb0d83baa8625eab")
-        (revision "0"))
-    (package
-      (name "gnome-shell-extension-hide-app-icon")
-      (version (git-version "2.7" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url (string-append "https://github.com/michael-rapp"
-                                   "/gnome-shell-extension-hide-app-icon.git"))
-               (commit commit)))
-         (sha256
-          (base32
-           "1i28n4bz6wrhn07vpxkr6l1ljyn7g8frp5xrr11z3z32h2hxxcd6"))
-         (file-name (git-file-name name version))))
-      (build-system gnu-build-system)
-      (arguments
-       '(#:tests? #f                ; no test target
-         #:make-flags (list (string-append "EXTENSIONS_DIR="
-                                           (assoc-ref %outputs "out")
-                                           "/share/gnome-shell/extensions"))
-         #:phases
-         (modify-phases %standard-phases
-           (delete 'configure)      ; no configure script
-           (replace 'install
-             (lambda* (#:key outputs #:allow-other-keys)
-               (let ((out (assoc-ref outputs "out"))
-                     (pre "/share/gnome-shell/extensions/")
-                     (dir "hide-app-icon@mrapp.sourceforge.com"))
-                 (copy-recursively dir (string-append out pre dir))
-                 #t))))))
-      (native-inputs
-       (list `(,glib "bin") intltool))
-      (propagated-inputs
-       (list glib))
-      (synopsis "Hide app icon from GNOME's panel")
-      (description "This extension hides the icon and/or title of the
-currently focused application in the top panel of the GNOME shell.")
-      (home-page
-       "https://github.com/michael-rapp/gnome-shell-extension-hide-app-icon/")
-      (license
-        ;; README.md and LICENSE.txt disagree -- the former claims v3, the
-        ;; latter v2.  No mention of "or later" in either place or in the code.
-        (list license:gpl2
-              license:gpl3)))))
+  (deprecated-package "gnome-shell-extension-hide-app-icon"
+                      gnome-shell-extension-just-perfection))
 
 (define-public gnome-shell-extension-just-perfection
   (package