diff mbox series

[bug#60009,08/18] gnu: python-bokeh: Skip failing PIL test.

Message ID 20221212142716.9460-8-rekado@elephly.net
State New
Headers show
Series [bug#60009,01/18] gnu: python-graphviz: Update to 0.20.1. | expand

Commit Message

Ricardo Wurmus Dec. 12, 2022, 2:27 p.m. UTC
The result seems fine, so don't worry about it.

* gnu/packages/python-xyz.scm (python-bokeh)[arguments]: Ignore failing
test_transform_PIL test.
---
 gnu/packages/python-xyz.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

Comments

Simon Tournier Dec. 12, 2022, 7:10 p.m. UTC | #1
Hi Ricardo,

On Mon, 12 Dec 2022 at 15:27, Ricardo Wurmus <rekado@elephly.net> wrote:

> The result seems fine, so don't worry about it.

Is this intended to be in the commit message?


Cheers,
simon
Ricardo Wurmus Dec. 12, 2022, 8:09 p.m. UTC | #2
zimoun <zimon.toutoune@gmail.com> writes:

> On Mon, 12 Dec 2022 at 15:27, Ricardo Wurmus <rekado@elephly.net> wrote:
>
>> The result seems fine, so don't worry about it.
>
> Is this intended to be in the commit message?

Yes.  The test compares base64-encoded gifs; the gifs look identical but
the base64-encoded data differs.  Hence the note in the commit message
that disabling this PIL test is probably fine.
Simon Tournier Dec. 12, 2022, 8:37 p.m. UTC | #3
Hi,

On Mon, 12 Dec 2022 at 21:10, Ricardo Wurmus <rekado@elephly.net> wrote:

> >> The result seems fine, so don't worry about it.

> Yes.  The test compares base64-encoded gifs; the gifs look identical but
> the base64-encoded data differs.  Hence the note in the commit message
> that disabling this PIL test is probably fine.

That also in the comment. :-)

Well, when I read it, I have been confused but this line, so maybe the
"about it." could be explicit: "about the failing test."

Cheers,
simon
Ricardo Wurmus Dec. 12, 2022, 11:06 p.m. UTC | #4
Simon Tournier <zimon.toutoune@gmail.com> writes:

> Hi,
>
> On Mon, 12 Dec 2022 at 21:10, Ricardo Wurmus <rekado@elephly.net> wrote:
>
>> >> The result seems fine, so don't worry about it.
>
>> Yes.  The test compares base64-encoded gifs; the gifs look identical but
>> the base64-encoded data differs.  Hence the note in the commit message
>> that disabling this PIL test is probably fine.
>
> That also in the comment. :-)
>
> Well, when I read it, I have been confused but this line, so maybe the
> "about it." could be explicit: "about the failing test."

Okay, I’ll make the note a little more explicit.

Thanks for the comments!
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8591423116..c63ba212b0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15465,7 +15465,10 @@  (define-public python-bokeh
                (delete-file "tests/unit/bokeh/models/test_sources.py")
                (delete-file "tests/unit/bokeh/embed/test_bundle.py")
 
-               (invoke "pytest" "-v")))))))
+               ;; XXX: This one test transforms a gif of a red box.  It
+               ;; transforms it all right but the base64 doesn't look as
+               ;; expected, probably because of a change in pillow.
+               (invoke "pytest" "-v" "-k" "not test_transform_PIL")))))))
     (propagated-inputs
      (list node-lts
            python-jinja2