diff mbox series

[bug#60009,05/18] gnu: python-pygenometracks: Update to 3.5.

Message ID 20221212142716.9460-5-rekado@elephly.net
State New
Headers show
Series [bug#60009,01/18] gnu: python-graphviz: Update to 0.20.1. | expand

Commit Message

Ricardo Wurmus Dec. 12, 2022, 2:27 p.m. UTC
* gnu/packages/bioinformatics.scm (python-pygenometracks): Update to 3.5.
[build-system]: Use pyproject-build-system.
[arguments]: Quote phases instead of full list of arguments; remove trailing #T
from build phase.
---
 gnu/packages/bioinformatics.scm | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 82801e7eeb..e6a8789ea6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13466,25 +13466,25 @@  (define-public python-hicexplorer
 (define-public python-pygenometracks
   (package
     (name "python-pygenometracks")
-    (version "3.3")
+    (version "3.5")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pyGenomeTracks" version))
        (sha256
         (base32
-         "16laa0wnf4qn9fb9ych4w1vqhqwjss70v0y0f6wp4gwqfrlgac0f"))))
-    (build-system python-build-system)
+         "1l7smg2gc1vm2181lzmdnywb11gp6s6z6j444dbsigv65car8z8p"))))
+    (build-system pyproject-build-system)
     (arguments
-     `(#:tests? #f ; there are none
-       #:phases
-       (modify-phases %standard-phases
+     (list
+      #:tests? #f                       ;there are none
+      #:phases
+      '(modify-phases %standard-phases
          (add-after 'unpack 'relax-requirements
            (lambda _
              (substitute* "setup.py"
                (("matplotlib ==3.1.1")
-                "matplotlib >=3.1.1"))
-             #t)))))
+                "matplotlib >=3.1.1")))))))
     (propagated-inputs
      (list python-future
            python-gffutils