diff mbox series

[bug#60009,14/18] gnu: python-apispec: Update to 6.0.2.

Message ID 20221212142716.9460-14-rekado@elephly.net
State New
Headers show
Series [bug#60009,01/18] gnu: python-graphviz: Update to 0.20.1. | expand

Commit Message

Ricardo Wurmus Dec. 12, 2022, 2:27 p.m. UTC
* gnu/packages/python-xyz.scm (python-apispec): Update to 6.0.2.
[build-system]: Use pyproject-build-system.
[arguments]: Disable test through test-flags, not by replacing the 'check
phase.
[propagated-inputs]: Remove python-pyyaml; add python-packaging.
[native-inputs]: Add python-flake8, python-flake8-bugbear, python-mypy,
python-pre-commit, and python-pyyaml.
---
 gnu/packages/python-xyz.scm | 39 ++++++++++++++++++++-----------------
 1 file changed, 21 insertions(+), 18 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7d9f420412..37c2caf400 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21011,33 +21011,36 @@  (define-public python-marshmallow-jsonapi
 (define-public python-apispec
   (package
     (name "python-apispec")
-    (version "4.0.0")
+    (version "6.0.2")
     (source
      (origin
-      (method url-fetch)
-      (uri (pypi-uri "apispec" version))
-      (sha256
+       (method url-fetch)
+       (uri (pypi-uri "apispec" version))
+       (sha256
         (base32
-          "12n4w5zkn4drcn8izq68vmixmqvz6abviqkdn4ip0kaax3jjh3in"))))
-    (build-system python-build-system)
+         "11vqxwdxmm7qmyhdbxk4gnx37nbzmn266ah92gi4pvzd76vq0vg7"))))
+    (build-system pyproject-build-system)
     (arguments
-     '(#:phases (modify-phases %standard-phases
-                  (replace 'check
-                    (lambda _
-                      (invoke "pytest" "-vv"
-                              ;; Disable validation tests since they require
-                              ;; the optional 'prance' library which is not
-                              ;; yet in Guix.
-                              "-k" "not openapi_tools_validate"))))))
+     (list
+      ;; Disable validation tests since they require
+      ;; the optional 'prance' library which is not
+      ;; yet in Guix.
+      #:test-flags '(list "-k" "not openapi_tools_validate")))
     (propagated-inputs
-     (list python-pyyaml))
+     (list python-packaging))
     (native-inputs
-     (list python-pytest python-marshmallow))
+     (list python-flake8
+           python-flake8-bugbear
+           python-marshmallow
+           python-mypy
+           python-pre-commit
+           python-pytest
+           python-pyyaml))
     (home-page "https://github.com/marshmallow-code/apispec")
     (synopsis "Swagger/OpenAPI specification generator")
     (description "@code{python-apispec} is a pluggable API specification
-     generator.  It currently supports the OpenAPI specification, formerly known
-     as Swagger.")
+generator.  It currently supports the OpenAPI specification, formerly known as
+Swagger.")
     (license license:expat)))
 
 (define-public python-apispec-webframeworks