diff mbox series

[bug#60009,15/18] gnu: python-pyjwt: Update to 2.6.0.

Message ID 20221212142716.9460-15-rekado@elephly.net
State New
Headers show
Series [bug#60009,01/18] gnu: python-graphviz: Update to 0.20.1. | expand

Commit Message

Ricardo Wurmus Dec. 12, 2022, 2:27 p.m. UTC
* gnu/packages/python-xyz.scm (python-pyjwt): Update to 2.6.0.
[build-system]: Use pyproject-build-system.
[arguments]: Remove.
[native-inputs]: Add pytohn-coverage, python-pre-commit, python-sphinx, and
python-sphinx-rtd-theme.
---
 gnu/packages/python-xyz.scm | 19 +++++++++----------
 1 file changed, 9 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 37c2caf400..a6983e4411 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4087,23 +4087,22 @@  (define-public python-text-unidecode
 (define-public python-pyjwt
   (package
     (name "python-pyjwt")
-    (version "2.4.0")
+    (version "2.6.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "PyJWT" version))
        (sha256
         (base32
-         "1fmbcwfw1463wjzwbcgg3s16rad6kfb1mc5y7jbkp6v9ihh0hafl"))))
-    (build-system python-build-system)
-    (arguments
-     '(#:phases (modify-phases %standard-phases
-                  (replace 'check
-                    (lambda* (#:key tests? #:allow-other-keys)
-                      (when tests?
-                        (invoke "pytest" "-vv")))))))
+         "1z85kwr945rbzrn5wabrsmck5x8disa9wc7b3y5gci7w65z5qa39"))))
+    (build-system pyproject-build-system)
     (native-inputs
-     (list python-cryptography python-pytest))
+     (list python-coverage
+           python-cryptography
+           python-pre-commit
+           python-pytest
+           python-sphinx
+           python-sphinx-rtd-theme))
     (home-page "https://github.com/progrium/pyjwt")
     (synopsis "JSON Web Token implementation in Python")
     (description