diff mbox series

[bug#53019,1/6] gnu: Add python-codeclimate-test-reporter.

Message ID 20220701213302.13234-1-goodoldpaul@autistici.org
State New
Headers show
Series [bug#53019,1/6] gnu: Add python-codeclimate-test-reporter. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Giacomo Leidi July 1, 2022, 9:32 p.m. UTC
* gnu/packages/python-xyz.scm (python-codeclimate-test-reporter): New variable.
---
 gnu/packages/python-xyz.scm | 39 ++++++++++++++++++++++++++++++++++++-
 1 file changed, 38 insertions(+), 1 deletion(-)


base-commit: aba1ee5553099d45eb22d9ca1f685502146a49d0

Comments

M July 30, 2022, 9:09 p.m. UTC | #1
On 01-07-2022 23:32, Giacomo Leidi via Guix-patches via wrote:
> * gnu/packages/python-xyz.scm (python-codeclimate-test-reporter): New variable.
> ---
>   gnu/packages/python-xyz.scm | 39 ++++++++++++++++++++++++++++++++++++-
>   1 file changed, 38 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 1d43049776..23195bf86b 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -63,7 +63,7 @@
>   ;;; Copyright © 2019, 2020 Alex Griffin <a@ajgrf.com>
>   ;;; Copyright © 2019, 2020, 2021, 2022 Pierre Langlois <pierre.langlois@gmx.com>
>   ;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
> -;;; Copyright © 2019, 2020, 2021 Giacomo Leidi <goodoldpaul@autistici.org>
> +;;; Copyright © 2019-2022 Giacomo Leidi <goodoldpaul@autistici.org>
>   ;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
>   ;;; Copyright © 2019, 2020, 2021, 2022 Tanguy Le Carrour <tanguy@bioneland.org>
>   ;;; Copyright © 2019, 2021 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
> @@ -26275,6 +26275,43 @@ (define-public python-flufl-lock
>       (license (list license:asl2.0
>                      license:lgpl3))))    ; only for setup_helpers.py
>   
> +(define-public python-codeclimate-test-reporter

The README in the Git repository says it's deprecated, do we need it?

> +  (package
> +    (name "python-codeclimate-test-reporter")
> +    (version "0.2.3")
> +    (source
> +     (origin
> +       (method git-fetch)               ;no tests in pypi archive
> +       (uri (git-reference
> +             (url "https://github.com/codeclimate/python-test-reporter")
> +             (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> +         "0mxph5l3k9ch4hs9l76k4wnmzhd94bylg92lvm2priyn24gkn9a1"))))
> +    (build-system python-build-system)
> +    (native-inputs
> +     (list git-minimal/fixed
> +           python-httpretty
> +           python-pytest))
> +    (propagated-inputs
> +     (list (package
> +             (inherit python-coverage)
> +             (version "4.3.4")
> +             (source
> +              (origin
> +                (method url-fetch)
> +                (uri (pypi-uri "coverage" version))
> +                (sha256
> +                 (base32
> +                  "1prkwz1hkcbx19nsadbcmk4wl27ysx001pa8bykfagd3d87zxbpa")))))
> +           python-requests))
> +    (home-page "https://github.com/codeclimate/python-test-reporter")
> +    (synopsis "Reports test coverage to Code Climate")
> +    (description "This package provides @{codclimate-test-reporter}, a Python
> +library teport test coverage to Code Climate.")
> +    (license license:expat)))

Typo: teport -> report, would also be nice to state more explicitly it 
uploads information to some website.

The service it communicates to (Code Climate) also doesn't appear to be 
free software, this isn't an automatic rejection (see, e.g., 
Facebook-related packages) but it's still rather "eergh, do we really 
have to?".

Greetings,
Maxime
vasilii.smirnov--- via Guix-patches" via Oct. 10, 2022, 8:51 p.m. UTC | #2
Dear Maxime,
On 2022-07-30 21:09, Maxime Devos wrote:
> 
> Typo: teport -> report, would also be nice to state more explicitly it
> uploads information to some website.
> 
> The service it communicates to (Code Climate) also doesn't appear to
> be free software, this isn't an automatic rejection (see, e.g.,
> Facebook-related packages) but it's still rather "eergh, do we really
> have to?".
It turns out we don't :) I removed the package.

Thank you,

giacomo
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1d43049776..23195bf86b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -63,7 +63,7 @@ 
 ;;; Copyright © 2019, 2020 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2019, 2020, 2021, 2022 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
-;;; Copyright © 2019, 2020, 2021 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2019-2022 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
 ;;; Copyright © 2019, 2020, 2021, 2022 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2019, 2021 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
@@ -26275,6 +26275,43 @@  (define-public python-flufl-lock
     (license (list license:asl2.0
                    license:lgpl3))))    ; only for setup_helpers.py
 
+(define-public python-codeclimate-test-reporter
+  (package
+    (name "python-codeclimate-test-reporter")
+    (version "0.2.3")
+    (source
+     (origin
+       (method git-fetch)               ;no tests in pypi archive
+       (uri (git-reference
+             (url "https://github.com/codeclimate/python-test-reporter")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0mxph5l3k9ch4hs9l76k4wnmzhd94bylg92lvm2priyn24gkn9a1"))))
+    (build-system python-build-system)
+    (native-inputs
+     (list git-minimal/fixed
+           python-httpretty
+           python-pytest))
+    (propagated-inputs
+     (list (package
+             (inherit python-coverage)
+             (version "4.3.4")
+             (source
+              (origin
+                (method url-fetch)
+                (uri (pypi-uri "coverage" version))
+                (sha256
+                 (base32
+                  "1prkwz1hkcbx19nsadbcmk4wl27ysx001pa8bykfagd3d87zxbpa")))))
+           python-requests))
+    (home-page "https://github.com/codeclimate/python-test-reporter")
+    (synopsis "Reports test coverage to Code Climate")
+    (description "This package provides @{codclimate-test-reporter}, a Python
+library teport test coverage to Code Climate.")
+    (license license:expat)))
+
 (define-public python-flufl-testing
   (package
     (name "python-flufl-testing")