diff mbox series

[bug#53019,3/6] gnu: python-codecov: Update to 2.1.12.

Message ID 20220701213302.13234-3-goodoldpaul@autistici.org
State New
Headers show
Series [bug#53019,1/6] gnu: Add python-codeclimate-test-reporter. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Giacomo Leidi July 1, 2022, 9:32 p.m. UTC
* gnu/packages/check.scm (python-codecov): Update to 2.1.12.
---
 gnu/packages/check.scm | 16 ++++++++++++----
 1 file changed, 12 insertions(+), 4 deletions(-)

Comments

M July 30, 2022, 9:02 p.m. UTC | #1
On 01-07-2022 23:32, Giacomo Leidi via Guix-patches via wrote:
> +    (arguments
> +     (list
> +      ;; 3 failed, 47 passed, 21 skipped, 1 warning
> +      #:tests? #f))

By disabling tests when they detect problems, we defeat the point of 
having tests. A 'failing' test is a good test, as it detected a problem 
(hopefully not a false positive ...) before the buggy result is actually 
used for real.

It's like, say, firing a building inspector because they noticed that 
the building would fall over in case of some wind from an unanticipated 
direction, instead of making the building more sturdy, changing the 
building plan or not proceeding with actually building the building.

What problems did the tests detect?

Greetings,
Maxime.
Deslauriers, Douglas via Guix-patches" via Oct. 10, 2022, 8:50 p.m. UTC | #2
Dear Maxime,
On 2022-07-30 21:02, Maxime Devos wrote:
> On 01-07-2022 23:32, Giacomo Leidi via Guix-patches via wrote:
>> +    (arguments
>> +     (list
>> +      ;; 3 failed, 47 passed, 21 skipped, 1 warning
>> +      #:tests? #f))
> 
> By disabling tests when they detect problems, we defeat the point of
> having tests. A 'failing' test is a good test, as it detected a
> problem (hopefully not a false positive ...) before the buggy result
> is actually used for real.
> 
> It's like, say, firing a building inspector because they noticed that
> the building would fall over in case of some wind from an
> unanticipated direction, instead of making the building more sturdy,
> changing the building plan or not proceeding with actually building
> the building.
> 
> What problems did the tests detect?
Some tests depend on network access, I now identified and disabled them.

Thank you,

giacomo
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index f2871690a5..58af53388e 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1821,19 +1821,27 @@  (define-public python-cov-core
 (define-public python-codecov
   (package
     (name "python-codecov")
-    (version "2.0.15")
+    (version "2.1.12")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "codecov" version))
         (sha256
          (base32
-          "1217c0vqf7ii65635gvl27a5pfhv0r7zhrpdp9cx640hg73bgn4f"))))
+          "1haipizcyr6wnqavrfxwzhvjvqcfxy6r745gjnl6shi5a2xldnm0"))))
     (build-system python-build-system)
+    (arguments
+     (list
+      ;; 3 failed, 47 passed, 21 skipped, 1 warning
+      #:tests? #f))
     (native-inputs
-     (list python-unittest2))
+     (list python-ddt
+           python-mock
+           python-pytest
+           python-pytest-cov
+           python-requests))
     (propagated-inputs
-     (list python-coverage python-requests))
+     (list python-coverage-5.5 python-requests))
     (home-page "https://github.com/codecov/codecov-python")
     (synopsis "Upload code coverage reports to @code{codecov.io}")
     (description