diff mbox series

[bug#53019,2/6] gnu: Add python-coverage-5.5

Message ID 20220701213302.13234-2-goodoldpaul@autistici.org
State New
Headers show
Series [bug#53019,1/6] gnu: Add python-codeclimate-test-reporter. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Giacomo Leidi July 1, 2022, 9:32 p.m. UTC
* gnu/packages/check.scm (python-coverage-5.5): New variable.
---
 gnu/packages/check.scm | 13 +++++++++++++
 1 file changed, 13 insertions(+)

Comments

M July 30, 2022, 9:04 p.m. UTC | #1
On 01-07-2022 23:32, Giacomo Leidi via Guix-patches via wrote:
> * gnu/packages/check.scm (python-coverage-5.5): New variable.
> ---
>   gnu/packages/check.scm | 13 +++++++++++++
>   1 file changed, 13 insertions(+)
>
> diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
> index 6ad2b1acd8..f2871690a5 100644
> --- a/gnu/packages/check.scm
> +++ b/gnu/packages/check.scm
> @@ -38,6 +38,7 @@
>   ;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
>   ;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
>   ;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
> +;;; Copyright © 2022 Giacomo Leidi <goodoldpaul@autistici.org>
>   ;;;
>   ;;; This file is part of GNU Guix.
>   ;;;
> @@ -1745,6 +1746,18 @@ (define-public python-coverage
>   executed.")
>       (license license:bsd-3)))
>   
> +(define-public python-coverage-5.5
> +  (package
> +    (inherit python-coverage)
> +    (version "5.5")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "coverage" version))
> +       (sha256
> +        (base32
> +         "0b112ly7vvplvm9l411aqknxhr7fzfyp28xhflhkcx78l3lqzrzb"))))))
> +

Why not update the already-existing python-coverage package? Then all 
users of that package would benefit and propagation conflicts would be 
avoided.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 6ad2b1acd8..f2871690a5 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -38,6 +38,7 @@ 
 ;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
 ;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2022 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1745,6 +1746,18 @@  (define-public python-coverage
 executed.")
     (license license:bsd-3)))
 
+(define-public python-coverage-5.5
+  (package
+    (inherit python-coverage)
+    (version "5.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "coverage" version))
+       (sha256
+        (base32
+         "0b112ly7vvplvm9l411aqknxhr7fzfyp28xhflhkcx78l3lqzrzb"))))))
+
 (define-public python-pytest-asyncio
   (package
     (name "python-pytest-asyncio")